Docker images for Roon [Please Note: Using Dockers and VMs isn't supported by Roon]

I don’t think this is a port issue. If there was a port conflict with other docker app RoonServer will not even start, but it clearly runs. However, access to the main interface is blocked for some reason.
Recently, I worked on dockerizing Asp.Net Core app and part of the application is hangfire server. Access to this server is blocked by default unless it is configured for giving access to registered users. This is done in Startup class. This might be similar situation. I did clean install with new folders. I was greeted with window where I had to put my credentials and after that it stopped. I got email from RoonLabs about new signing. This would suggest that authentication is not a issue.

On the other hand, you had no problems at all. This is really strange.

Yes it is indeed.

Maybe we can invite support to chime in for ideas…

1 Like

I stopped all docker apps and started RoonServer only! This time it worked. I uninstalled RoonServer and installed again, this time pointing to older folders from previous setup and again everything worked.
Why there was an issue at the first place? I do not know.

Computers… :thinking:

Great to hear you solved it!

1 Like

I have narrowed it down to be a roon vs emby conflict. I think I had this problem before, I fixed it by changing a path and/or path mapping in emby. This time, I fixed it a different way - by deleting emby port 1900 allocation (DNLA UDP). So now, it seems everything is working, both emby and roon, and remotes for both. Here is details for the port allocation I deleted:
I think this came automatically with the container by linuxserver. It said “optional”, so I deleted it. I don’t know what it is for, or if I will discover other problems later.

Can I assign a port number to the roon container?

I never got Roon to work reliable by assigning port numbers instead of “host networking” from Docker. In theory it should be possible however. Prepare yourself for some problem solving however.

This old thread suggests some UDP and TCP ports

Then I won’t try assigning any port.

For UDP and TCP port reference link, I guess they are referring to setting up port forwarding. I hope i don’t need to do that cause I don’t understand it well. Maybe mine is already set correctly.

Happened on my machine as well with Plex, just remap port 1900 to something else on host side and it’ll be fine

@Steef_de_Bruijn I just installed roonserver on unraid and am unable to play qobuz. I can play my local media just fine. I am unable to try Tidal as my subscription ran out.

The logs in unraid don’t show anything. Can I get any info for you to help? Thank you in advance.


If Roon on itself is running fine, playing music (so you are able to control it from a remote too I guess), I suspect this is more a problem related to your resource and/or network setup of unraid than of Roon and/or the docker setup.

I hope people that are better equipped with unraid knowledge can chime in to help. You can also try the unraid forum.

The unraid logs show nothing you say. What do the Roon logs tell you?


I’m in the roon logs by way of docker and it just shows the startup info

% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
e[0;37;1me[0;0m00:00:00.000 e[0;31mWarn: get lock file path: /tmp/.rnsgem0-e[0;0m
aac_fixed decoder found, checking libavcodec version...

has mp3float: 1, aac_fixed: 1
System.Net.Sockets.SocketException (104): Connection reset by peer
at System.Net.Sockets.Socket.EndReceive(IAsyncResult asyncResult)
at Sooloos.RnetJsonClient.<>c__DisplayClass65_0.<_BeginRead>b__0(IAsyncResult ar)
e[0;37;1me[0;0m00:00:00.005 e[0;31mWarn: get lock file path: /tmp/.rnsgem0-e[0;0m

Not sure if theres a clue there. I have it set to host so it should run as expected. I also have Plex but have disabled the DLNA server which is what uses port 1900, so it shouldn’t be that, unless I’m wrong.

Edit: The error I’m receiving is “This track is currently not available from qobuz” but I know it is. Checked my pihole and nothing is being blocked

I’m a docker noob playing around, and am havbing trouble with what I am sure is basic stuff.

How do I connect the docker to a network share? - I can share nfs to a mount point on the host machine, but can’t fuigure out how to pass that to the odker installation, or how to share directly to the docker instance.

If this is the wrong place for this question, please let me know and I’ll move it.

How are you running the container? A few details like the host OS, network arrangement and docker run ... details would make helping a little easier please. You’ll either need to share a host dir/mount point with the container as a docker volume, using the -v flag for your run command, e.g. docker run -v host_path: container_path. If you’re using docker from the command line read this section of the manual.

If your container is on the same network as the NFS share then you can access it from within Roon. Something like:

Good luck

1 Like

I’m using the docker run from steefdebruijn/docker-roonserver

Host OS is Ubuntu server

Network share is configured for nfs and for smb. no matter what I tyope in the roon network share location box, I get an “There was an unexpected error: Unexpected Error” reply. They hould be on the same network, I have not setup any plans or anything, but I’m so new to docker I’m not sure what it is passing from the host os.

I’ve gotten roon up on debian prior to this, through mounting my music as a cifs share.

What does your docker run… command look like, please.

This is the one I used trying to point the -v at my mount point for nfs

sudo docker run -d
-e TZ=“America/Los_Angeles”
-v roon-app:/app
-v roon-data:/data
-v roon-music:/mountDS920/music
-v roon-backups:/backup

well, I don’t know if I did it right, but it works.

sudo docker run --cap-add SYS_ADMIN --cap-add DAC_READ_SEARCH --security-opt apparmor:unconfined -d \
  --net=host \
  -e TZ="America/Los_Angeles" \
  -v roon-app:/app \
  -v roon-data:/data \
  -v roon-music:/mountDS920/music \
  -v roon-backups:/backup \

Seems to lose it’s connection to the core randomly though. Get the time out thingy, then it reconnects.

1 Like

about year ago i had similar issue - it was caused by roon in docker being confused due to my server having 2 LAN ports (one 10GbE the other regular 1Gb). I solved it by creating docker network to ensure roon server sees only one of the adapters … in the meantime i re-installed the server and it seems to work fine without that ‘hack’.
if you have 2 adapters, send me a message and will give you directions.

1 Like

Thanks @Steef_de_Bruijn for a trouble-free Roon server container. I’ve been running it for quite a while on various platforms. For the last several months it’s been flawless through several upgrades running on an antique Nuc under Alpine. I had been using macvlan networking on a previous incarnation on a very much busier, port congested server. Once I got past the macvlan noob stage, it worked well. When I moved to the Alpine Nuc there was really no reason justifying macvlan’s complexity, and host mode was perfectly adequate. Great work, very much appreciated.

1 Like

Thank you for your kind words. Appreciated.