Does anyone run Roon Core and Bridge as a Virtual Machine?

Cheers, Graham. Running Roon on Ubuntu 18.04 – machine serves Plex, Roon, family file server. Stuffed up my Roon extensions a while back, and the idea of rebuilding the whole machine is painful. What you’re describing sounds ideal. Appreciate the pointer.


Yeah it works well. The key is to have only one service per container e.g. Plex or Roon or… then each service effectively has it’s own virtual machine so rebuilding/changing becomes really fast and simple. The containers act like completely independent Linux machines but share low level resources so you can easily have multiple running on a moderately specced PC running Proxmox. Also, run the containers without GUI - i.e. Ubuntu server as this keeps the resource use way down.

1 Like

Sweet, thank you. Sounds perfect for what I’m running. Experimenting to come.

1 Like

Hey there, I run Roon Core in a VM on ESXi but I’d like to use Roon Rock instead. How dod you get that image to boot? what steps did you take?

It has been over a year and, knock on wood, it’s still going strong so I’ve not had to repeat the procedure which is really good because I’ve lost my notes. So… from memory…

I could never get it to install in ESXi. I tried all the tricks I could find for attaching a physical keyboard to the VM in order to get past the “press key to continue” but nothing worked. Plan B was to use VMWare Fusion to do the install.

VMWare Fusion allowed me to complete the install without any issue. I think exported the Fusion VM to OVA and this gave me a compatible disk image which I imported into ESXi. That is how I was able to get ROCK booted under ESXi. I just don’t remember the specific steps I used. All of my music is stored on an external USB drive. I did it this way so that I could have physical access to the drive if needed for back-ups and such. The VM is configured to direct attach the drive.

I am also running Roon Server on ESXi. Debian Buster machine.
I also have a ROCK vm, but because is a closed system I don’t like it.
I cannot install, for example, Extension Manager.

I have been running ROCK in a headless Parallels VM (bridged networking with static IP) for about a month now, all good, way better than running server directly in the Mac.

I was going to launch a VM just for extensions but that seemed like a waste of resources so never did it. Finally threw diet-pi on a RaspPi 3B+ and loaded extensions there. That’s been working very fine. I really like the hands-off of ROCK… until I have to troubleshoot something.

I am stuck at missing codecs point. I have raised below support ticket. Any help welcome!

I did not went the Proxmox VE path because it needs a dedicated server or could I install in a virtual machine?

One more vote for Proxmox.

I am running it in not a extremely powerful NUC (dual i3 with 16gb).

I have room server with HQP in one VM plus other VMs and running perfectly well.

1 Like

How did you managed to install the missing codecs please ? Or you don’t care because you don’t have some mp3 remaining in your library ?

Most of my files are Flac but I do have some mp3.

I have resolved my issue and now my VM machine is fully functional with Codecs working.

I am copying the ffmpeg file from a Linux VM to ROCK VM and previously was connected as anonymous to the SMB share. Althougth the file was looking like copied, ROCK did not took it in account.

This time I connected to the SMB ROCK share using my Windows Host account details. I have copied the ffmpeg file and this time ROCK took it in account and I am all OK with all codecs installed!

1 Like

I’m running a roon core on a nvme drive as an Ubuntu server VM inside a server running Unraid. My music is on a separate ssd drive. Everything is very snappy. I use the box for lots of other things (Plex, geeky stuff). If anyone wants to consolidate to a single do it all machine, I’d really recommend using Unraid! It can run docker containers too, I went the vm route just for more of a traditional deploy and simple backups. Everything also syncs to the backblaze cloud for pretty cheap money so if the box dies I get an easy restore. Just in case it helps anybody else looking for a similar solution.

1 Like

I’ve just bought a 10th Gen i5 and whacked 32 GB RAM + 500GB NVME in it for this purpose. :slight_smile:

While I’m tempted to go the ROCK route, it seems that it’s likely asking for trouble doing it in Unraid. What specs are on your machine @IainB? And it sounds like you went with Ubuntu server, but did you consider/try using Ubuntu Core?

Hi @Nic

I’ve got an AMD 2600 with 64GB RAM. It really does do a bit of everything as I work in IT and run vms, containers etc… I didn’t consider Ubuntu core as I used the roon server installer script and thought the chances of it working on core with it was slim. I only have the Ubuntu server running with 2 cpus and 2GB ram, and it seems plenty. I do stream from tidal mostly so don’t have a massive personal library. But, a VM is working great. I didn’t go down the rock route as I didn’t really see a benefit, I guess it is a Linux system under the hood and would install fine in a VM, but perhaps there are some weird issues as it expects to be installed on a native piece of hardware. But yeah, simple and vanilla VM install is working for me. I definitely haven’t overcomplicated anything! To me it just installed and runs like anything else, nothing mystical about it. I haven’t touched it since. Hope that helps.

I used Ubuntu 19.09 LTS and I think I had to install these dependencies first.

sudo apt install curl ffmpeg cifs-utils -y

Super helpful, thanks so much!
My current status is “can’t even get Unraid to boot”, but hopefully I’ll be over that speedbump soon enough. :slight_smile:

after jumping my core from many physical and virtual machines I think I got to the right place, 2cpu 4gb ram Ubuntu server 20 VM running as a FreeNAS VM. Later on today I will lower the RAM to 2gb as I do see no need of the 4GB, ZFS cache will do better use of it.

1 Like

Running a Older Dell XPS PC via Linux OS “MX Linux”, Inside the OS using Oracle Virtual Box.
Oracle VB loads Dietpi Linux that in turn is running Roon Bridge and Roon Extensions. The Roon Core, Settings/Audio pipes Roon Sound to this endpoint via the VB Dietpi and I can use it as a endpoint.

I used Mike Plugge Web Controller for the extensions. See this link for the details
Thanks goes out to this roon user: armandhammer absolutly brilliant stuff.

All I did was installed Roon Bridge inside Dietpi.

Why? I could not install Roon Bridge in MX directly No Systemd in Debian MX. So Oracle VirtualBox was the remedy. The more I use this stuff the more I like it. This is nuts…VB runs Sun-Solaris too.

I’ve got 3 Ubuntu 20.04.2 LTS VMs (VMware) running on a 2018 Mac mini (Core i7, 16GB RAM). One of the VMs is dedicated to my Roon Core.

I am on a Roon trial and I am running Roon in a docker on Unraid and it has been running flawlessly for over a week.

I am hopeful that Roon is running a Black Friday sale???

I like what Roon is doing for my library and Tidal subscription so far.