Does my ROCK "Appliance" need the 1.7 Update?

Started this topic yesterday, but then withdrew it because I’m not sure I was even asking a sensible question (Sorry!). Well, here it is again, hopefully more clearly stated. I have a network-connected ROCK-based NUC “appliance” that I use only for multichannel HDMI output (maybe also for USB output in the future). It is Celeron-based and is not the Roon Core (I have a more powerful i7 NUC I use for that). It has the Roon Server 1.6(Build 416) version that was installed along with the ROCK OS. It does not auto-update like my Core, Roon iOS remotes, and my Roon PC installations do (which are all at 1.7 now). It will also not auto-update its firmware (it’s on Build 175). Is there any point in being concerned about this? Not sure what to do to get it to update; I’ve tried rebooting and restarting the Server applications, but no change (I’m thinking I might have to do a ROCK reinstall to get the update).

My thinking is that since it’s not the Server (core) and probably doesn’t really use much, if any, of that portion of ROCK, it doesn’t matter. It probably only uses the RoonBridge portion of the ROCK OS. Is my thinking correct on this? Guess what I’m really asking is there any conceivable advantage to having the new 1.7 Version of RoonServer on an “appliance”-type of ROCK NUC? Truthfully, I haven’t even used it since the 1.7 update came online, but it’s still connected to and accessible through the network.

No you don’t need to update it, but it wont do any harm if you do.

1 Like

Thanks, CG. Is a reinstall of the newest ROCK OS the only way to update it?

Just go to the webgui and choose reinstall OS that will take care of it. What I just did.

1 Like

It will auto update depending on your settings. Go to Settings/About and you’ll see all your devices, and the software version they are running. If an update is required there will be an Update and Relaunch option on that page beside each device.

Perfecto! Was a little hesistant at first, but went for it and the reinstall worked flawlessly and only took about 2 minutes. Both RoonServer and firmware updated to the latest. Thanks again!

It’s good to see you have your RoonBridge endpoints showing up in the “About” Settings. The ROCK NUC I’m referring to is not the Core and doesn’t seem to show up in this section. It shows up in the “Audio” Section and works just fine. I would be curious to see if any other Roon Users with an “auxiliary” ROCK NUC implemented like mine (used as just a transport/endpoint) have their units showing up in the “About” section like your Bridges do. The NUC runs the linux-based ROCK as its OS, is not identified as the Core, and doesn’t have the RoonBridge, per se, installed as a separate application.

However, the update went just fine when I did the ROCK OS reinstall via the unit’s webgui like CrystalGipsy recommended. Don’t know if I really needed it, but why not? :slightly_smiling_face:

1 Like

It is treated differently so won’t show up in ‘about’ and can’t be updated from the core. The two main methods are from the web admin page or to actually log into it.

1 Like

You need to reinstall in the Web GUI as its not a device you log into roon on (as its not the core) - I just did the same thing to mine that is an Intel Fanless D510MO board.

1 Like

Thanks! Very good info for those of us with similar ROCK/Roon components. Makes a lot of sense.

Thanks! Already did (see several posts above). Went as flawlessly as any update. Am glad to see others with the same type of ROCK (or similar) implementations realize this and are on the same page.

I have the same circumstance as the OP, a ROCK serving as endpoint, that refuses to update to 1.7. I have reinstalled via the Web GUI, but my OS remains at v1 B182, and the server is v1.6, B425.

I’m happy for the OP’s success, and somewhat irked at my lack of it. Any assistance appreciated.

I would start new a support thread with your details all filled in

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.