Does Roon Server Software reboot itself on ROCK? [Resolved with Roon 1.8 (Build 806)]

My ROCK GUI shows the “Operating System” as being up for 8+ days, but the “Roon Server Software” only running for 7+ hours.

I’ve been home all day, playing music nearly that whole time, and not messing with any settings or anything, just playing music as normal.

Not a problem, just curious why/how this could occur. Thanks.

Did you recently update? The update process restart the server but usually not the OS.

It also can crash. It happened to me once. Not to worry unless it occurs again/repeatedly.

1 Like

No recent update.

Cool if it auto-restarts after a crash.

Apparently it does reboot itself.

I was listening to music and it stopped playing abruptly. I looked up and the disk access light on my NUC was going crazy. I went to the Rock GUI as quickly as I could, and it shows Roon Server Software running for 32 seconds. So, obviously it just crashed and restarted itself.

Anybody @support have any ideas why this would happen/be happening?

This happened at 8:50pm EDT, January 11 for log-checking purposes.

Have you tried reinstall of OS?

Next I would try reset and restore of db. Something is corrupt.

Thanks for the reply, Larry. I have not tried either of those things yet. My NUC/ROCK install is maybe two weeks old, so I’m curious how/why it would have gotten corrupted so quickly if that is indeed what is happening.

I’m having another issue with slow Tidal (but not Qobuz) that has progressed to the point of trying a fresh database as a troubleshooting step, so we’ll see… That said, it’s been up for 21 hours at this point, so…

I’d still like to get some official word on if this is at all normal or has been seen before, etc. from support before I go chasing ghosts…

In my experience of 3 years running rock this is not normal at all.

Perhaps a bad memory module or sad drive.

Hi @jtnt,

Thanks for the report! I’ve enabled diagnostics on your account so we can take a look.

In addition to this, can you use the directions found here and send us over a set of logs using a shared Dropbox link?


Are you using the original power supply not third party LPS?

Original power supply.

Thanks for the reply, @dylan. I’ll do that ASAP (likely this weekend).

FWIW, it’s been running for 3+ days now…

@dylan Saw how easy it was to zip up the logs and send them, so went ahead and did it. Here you go:

Thanks for sending that over, @jtnt. We’ll take a look and follow up soon!

1 Like

Hi @jtnt,

I spoke with the team this morning about their research into your logs. Unfortunately it looks like RAATServer logs were uploaded, which don’t give us a full picture of what might be happening. Can you send us Logs from the RoonServer folder as well and we’ll take a look ASAP? Thanks!

@dylan Oof :man_facepalming: - sorry about that. Here you go:

FWIW, just like when you bring your car into the shop and it doesn’t make the noise it was making for you, this seems to have not happened since I reported/noticed it last week.

Thanks, @jtnt. I’m glad to hear that it hasn’t happened since! I’ll get this over to the team but if it does occur again, can you send us a new set of logs right after it happens? It would definitely be helpful to see a recent instant of this as well.

@dylan Will do. I had to shutdown/reboot the entire NUC a couple days ago while moving some things around, so we’ll see if it happens again…

I work for an amplifier manufacturer, so I am often play-testing equipment in my system and so my system is played nearly 24-hours a day sometimes (and currently, this week), so presumably, if it’s gonna happen, it will happen at some point during this sort of constant operation.

And because of the aforementioned reboot, it will be easy to see if it does happen, as the uptime will be different between the server and the OS if it does.

Thanks for the continued attention - and patience. :slight_smile:

@dylan Hey. It just happened about 5 minutes ago, at 4:46pm EDT on Jan 23.

OS had been up for nearly 5 days. Music had been playing continuously for many hours and was currently choosing songs automatically via Roon Radio.

Here are the logs:

Thanks for sending those over, @jtnt! I’ll follow up as soon as we have feedback from the team on this.

1 Like

I’m having the same problem @jtnt did you get this sorted? My ROCK server just reboots for no apparent reason, usually late at night here in the UK. I’ve increased RAM to 8GB on the NUC but it still reset last night, getting to be quite a pain actually, just really cuts through the music when everything stops and takes minutes to come back - destroys the mood completely. Once or twice I just shut off the system and went to bed :unamused:

I’m wondering who else has this issue and hasn’t reported it? Or maybe the reset happened when they weren’t listening? The problem is there are no diagnostic tools on the ROCK web page, all we get to know is how long it has been up and running - I’m in the dark really?