Does RoonServer conflict with internet connectivity?

Is it possible that Roon Server itself is somehow interfering with my internet connection? After many tries, I was able to make a connection long enough to add my library. In the background Roon is running analysis. I noticed that if I stop the roon service, my internet connection returns to normal. Of course, before analysis was even possible, connectivity was an issue preventing progress in setting up 1.3.

As it stands, with Roon Server running, even connections to local area networks slow to a crawl. tested this multiple times. I’ve done most of the trouble shooting I can think of including multiple different network configurations, calling my ISP to make sure it’s not on their end. Open to suggestions.

This wasnt meant to be public. If it had I would have preferred to blank out my ip addresses and locations.

Hi @lorin — my apologies, I will adjust your screenshots accordingly.


I think my response got eaten, I have to remember to stop RoonServer for them to go through. Anyways, no worries, I just would have given more detail for a public post as its one of a great many posts with logs etc!

Seems I’m in a bit of a catch-22 with needing a network connection to set up Roon, and running Roon slows my network connection to an absolute crawl.

Just a note re: performance in case anyone’s wondering: even my meagre i5 was previously able to upsample to DSD256, analyze audio and browse the internet with no issue.

Currently I’m connecting to the internet with systemd’s networkd service. I also tried connman, Network Manager, Netctl. My tablets and phones are able to access other services on the local network such as my calibre server, router web admin, etc at normal speeds, provided the Roon service is not running.

These are the contents of roonserver.service




Managed to connect to Roon long enough to enter Tidal login details. Now back to chain disconnections. I am disheartened and depressed. The whole thing that convinced me to jump in with Roon was how easy it was to install and configure (even on Arch Linux!) compared to how long it took me to get uPNP + BubbleUp + HQPlayer going. Now I’m back in it.

Just wanted to give a quick update.

No change for me with Build 194. Connections from iOS to Linux still very flaky. Occasionally the main Roon screen shows, then almost immediately disconnects. With the previous build I was able eventually to point it to my media folder, and indexing was slowly progressing, so I know it’s capable of seeing my files. Perhaps related to the mysterious network problem, the analysis seemed to move at a crawl despite using substantial CPU time.

I can’t find a single thing wrong with my internet or local area network, unless RoonServer is running.

Log from initial run of 194:

Googling errors at the top of the log lead me to some posts vaguely about ipV6 Mono DNS problems. Disabled it at kernel level with ipv6disable=1. No dice. Same System.Net.DNS.Errors at the top of the log after rebooting. I’m not a programmer.

I am hoping there is something super obvious that I have missed about this problem, nothing would make me happier.

At the moment I am kinda in limbo with no way to know / find out whether this is an issue specific to my configuration or something that may be fixed. All I know is Roon worked flawlessly over the trial period and the weeks that passed since.

Here’s a screenshot of the running processes when I start my machine, running Arch Linux kernel 4.9.6-1. System is 100% up to date.

Here’s the output of pstree

Here’s a list of every package installed on my machine

Contents of /etc/nsswitch.conf :

Output of systemctl showing the state of services on startup:

List of set environment variable, output of export:

Build 196 still bringing my internet connection to a crawl.

Hey @lorin – thanks for your patience here. @Eric and I have been discussing this with the team, and it’s definitely unique, and not something we’re seeing other reports about.

So, something is different about your environment, network, configuration, or hardware, and we just need to figure out what that is. Then we should be able to resolve this, whether it’s something in your environment or an issue in Roon.

So, first off, can you elaborate on this a little?

Where are you seeing these errors? Have you sent us a screenshot or copy of this log? More details would help here.

Next up, can you give me some detailed information about your network? Hardware you’re using, how devices connect, how they get IP addresses, etc. Any detail, no matter how small, that might help us set up a similar network here so we can try to reproduce would be appreciated.

Get me those details and we will keep at it until we get this resolved for you. And one more time, thanks for your patience here @lorin!

My iOS devices are running io8 and 9. I’m loathe to update them because of performance issues, and whether or not they can connect doesn’t address DNS problem which strikes me as the root of this.

Oh, also wanted to mention as a datapoint: my mobile devices have normal internet performance with Roon running. From the iOS side, the flaky connection is specific to Roon Remote.

Any settings in your router that might be interfering with multicast or UDP ?

1 Like

Well I did say would be thrilled if it turned out to be something embarrasingly simple and @andybob I’m so glad you asked that.

It reminded me that the router was one of the very first things I looked into on Wednesday, even before I had identified some connection between my Roon and my internet. I was on the phone with support etc and we couldn’t turn anything up.

So moments ago, I reset the router to factory settings (vs. the safety pin reset we had tried), updated the firmware for good measure and voila, I started the updated Roon iOS client and my library is loading… And I can surf the internet while I watch it go.

I wish I understood better what that actually changed but… I’ll think about that later after some soul cleansing music at high decibels :smiling_imp:

Big thanks @support and all for bearing with me. I will report back if anything of further interest happens.


Unforuntalely, after a day away and zero changes to my system, I started up and am back where I started. So the router thing was a fluke, or?

Any leads as to how Roon could break my internet connection would be welcome. I’m about ready to give up here.

Lot of log files. Anyways, the errors I’m talking about are these

    02/02 20:01:37 Warn: [realtime] failed to get time: System.Net.Sockets.SocketException (0x80004005): Could not resolve host ''
  9   at System.Net.Dns.Error_11001 (System.String hostName) [0x00015] in <bd46d4d4f7964dfa9beea098499ab597>:0
 10   at System.Net.Dns.GetHostByName (System.String hostName) [0x00024] in <bd46d4d4f7964dfa9beea098499ab597>:0
 11   at System.Net.Dns.GetHostEntry (System.String hostNameOrAddress) [0x00061] in <bd46d4d4f7964dfa9beea098499ab597>:0
 12   at Sooloos.RealTime._FetchTimeFromServer (Base.ResultCallback`1[T] cb) [0x00044] in /home/roon/roon/RoonApp/realtime.cs:216

Many errors like this throughought my logs

49 02/02 20:01:38 Warn: Error in web request NetworkError (Error: NameResolutionFailure)
 50 02/02 20:01:38 Warn: Error in web request NetworkError (Error: NameResolutionFailure)

Which lead me to a very few links, (stuff like this and, again, not a programmer, so I’m not trying to say these are in any way useful to you at Roon, I’m just trying anything I can to find some clues. This is a rare occassion for me, not being able to crack a software problem like this. Especially as the entire Roon system worked so flawlessly previously.

So something is wrong with resolving DNS when roonserver.service is running? That’s my layman’s conclusion. When I start the service, all web traffic including connecting to 192.168.. addresses has a 5-10 second delay. When I stop it, all is well.

My network, if it can be so called, is really just a single computer (running Arch Linux with a 4.9 kernel and systemd 232-8) with a wired connection to a Cisco DPC3825 wireless router. I run Roon Remotes on my iPad Air 2 and iPod touch 6th gen, connected through the wireless network.

I’m starting Roon at boot as a systemd service, but I have also tried running it manually. Run manually as root, it passes the included script for compatibility. I recently tried the linux-lts kernel package (4.4.46-1) as there was an Arch Linux kernel upgrade on Feb 01st.

I’m using systemd-resolve for DNS and systemd-network d to start a simple wired network on boot. Contents of /etc/systemd/network/ are relatively simple:



I also tried DHCP=yes for that second heading, which enables ipv6 as well. No luck there.

Didn’t mean to post yet, I will add what else I think of in another comment.

Tried a variety of connection methods. I’ve switched back to NetworkManager which was serviceable for a long time. Removed the aur package and all its files (done several clean installs) and tried the basic install script from Roon’s site. Wracking my brain, I can’t think of anything particularly esoteric about my setup. Vanilla Arch packages.
The DNS configuration for NetworkManager uses the standard servers for my ISP, which work perfectly fine under regular circumstances.

Normally I would enjoy this sort of thing, but normally I would have solved the puzzle by now!

Thanks for the updates and sorry you are still having issues … I’ll leave a tag for @support folllow up with you.