Does RoPieee support the NuPrime uDSD DAC

Hey all,

Does RoPieee support the NuPrime uDSD DAC?

Best Regards


In essence RoPieee supports all USB DAC’s, so I would say: “yes” with a very high chance on success.


Thanks for the answer.

I guess I should have been a little more specific, sorry!

I was wondering if is supported things like native DSD playback.




It’s not in the list, so that means we did not run into it. So it’s a matter of you hooking it up, send feedback (that’s functionality of RoPieee) and then I can have a look if we can add it for supporting native DSD.

As for other NuPrime products this already works, so I’m hopeful :wink:

If you hook it up I can have a check real quick.


OK, great.

I have just bought one of these which basically combines a Raspberry Pi, power filter/supply and a uDSD.

Once I have it I’ll feedback and let you know how I get on.

Best Regards


1 Like

Hey @spockfish

I have the unit now. I have setup RoPieee via the web interface including enabling USB audio however it is not showing up in Roon at all!

I have sent you feedback. The id is b5dac0812dd57f71 . Could you please take a look for me.

Thanks very much


This is weird. You’re device is not even being seen at all.

So you’ve got it powered on right?

Yeah, by powered on you mean the DAC right? It appears to be…

can you check and hook it up to another USB port on the Pi?
because right now it’s simply invisible…

Ha Ha!

Figured it out!

It has a custom power supply that has two 5v feeds - one to the Pi and one to the DAC. I opened it up to check and noticed that the power supply to the DAC wasn’t even connected!!!

I have sent you another feedback. Could you check if it support Native DSD? The ID is 05533eb43dcabac8

Also, following instructions on another thread. I reinstalled RoonBridge using the following. Would that have caused any issues with RoPieee?

$ curl -O
$ chmod +x
$ ./

Thanks for all the help… :smiley:


Yes. I don’t know why you’re reinstalling RoonBridge as there is no need for it. This could potentially mess up your installation in the future.

Sorry, should I re-flash the SD card and start again?

So, there is no option for Native DSD in Roon. Is it possible/easy to add Native DSD support?

Depends on the device. I need to have a look at the logs.
‘Easy’ is a different story, as the kernel needs to be patched and rebuild.

Yeah this is doable. The NuPrime behaves like their other devices I already added.

I’ll prepare a patch for it.

That’s absolutely awesome!

Although I run into another problem now! Not having a good evening :frowning:

I got it working nice but I figured I do a fresh reinstall since I messed with RoonBridge but now I can access the web UI at all!

I get:

This site can’t be reached refused to connect.



I can ping it fine and sometimes I can SSH but no joy at all via a browser.

Any ideas?

By the way - I really appreciate all the work and support - it is amazing!

Best Regards


Have you tried connecting to ‘ropieee.local’?

Anyways, maybe something went wrong during installation, so a fresh install might be the best solution.
Keep in mind that during installation it needs to be hooked up to the internet.


OK, so I figured out what was wrong - or should I say I worked out how to get it working!!!

When I first setup RoPieee it worked first time but I couldn’t get the DAC to work. I took the lid off and it turns out that the cable that connected the internal USB hub wasn’t plugged in to the power board (I have attached an image so you can see what I mean) hence the reason it wasn’t ‘working’! I turned it off and connected the power cable and all worked fine!

I then decided to re-flash the SD with a fresh image of RoPieee and start again in case I managed to mess anything up the first time.

This time however I couldn’t get anything to work at all. I messed around with it for a while thinking it must be a networking issue. After a while I gave up and when to bed.

This morning I took another look. Fresh install and same issue.

Then I thought, why did it work the first time. And the only difference was the fact that the power cable to the hub/DAC wasn’t connected!

So I disconnected and started again and everything worked first time!!!

After I finished the setup of RoPieee, I turned it off and reconnected the hub/DAC and that all worked fine too!!!

I am vaguely interested in why it caused an issue but I am just glad I figured it out!

I am loving RoPieee and the DAC so far!

Thanks for all the help and sorry for being a pain :rofl:

Super excited about the next release with the native DSD support :sunglasses: