Does RoPieeeXL support audio out over RPi4 USB?

With RoPieeeXL loaded on a new RPi4, I’m stuck trying to configure Shairpoint-Sync or Librespot.

I’d like to output audio over the RPi USB port to a Shiit Asgard DAC / amp.

Does the warning “Hardware mixer not supported” mean this just isn’t possible? Thanks.

It (I think) means that Volume isn’t settable from outside of what Roon left it at. I use shairport and librespot no issues to USB and HATs alike, even though none of my hardware is mixer supported. You can still open roon and control the volume up or down by using the roon volume settings…a bit of a workaround but its there if you need it.

Yes, it works just fine. I have the RopieeXL connected with Ethernet and with USB to my DAC.

It works as a Roon End point. Hardware volume depends on the DAC.

Thank you both for your insights and personal configs. I was happy to hear your feedback and I appreciate it.

With USB output confirmed, I’m hoping I can ask for additional Shairport-Sync (Airplay) tips. None of my Apple devices can see the RopieeeXL as an Airplay device on my network.

In the Shairpoint-Sync settings, I’ve set “Audio Output” to USB, I’ve tried “Volume Control” as both available options Software and Off.

I know the Airplay fundamentals, so I’m stumped why RopieeeXL doesn’t show as an Airplay endpoint. It is ethernet connected, and the web admin page is accessible. On this same network, from both a MacBook and iPhone I can see my two AppleTV units via Airplay.

Even with a fresh download, etch, and setup tonight I’m not sure what to try next. Thoughts?

Thanks again for feedback you two. Happy to say I found my answer after lots of head scratching and reading. I should have followed the old adage “troubleshooting starts at the wall”.

The ethernet jack in my wall had open conductors! Apparently it wasn’t enough to keep my RPi4 offline since the Ropieee web interface has always worked, but it was enough to keep Airplay from working. Connecting my RPi to another port on my network and everything started working. I’ve got solid playback and volume control which is exactly what I wanted.

Take care all.