Does Windows actually do anything to the audio stream from Roon with Exclusive mode off or not?

I stream music from Qobuz via Roon to my HD600’s which are connected to the Zorloo Ztella DAC via USB C on my Windows PC. I need to switch audio sources during the day to allow for Teams calls, YouTube videos, Discord etc. I have found the easiest way to do this is to have Exclusive Mode always off.
I understand what this does but am actually I losing any audio quality by doing this?
I would like to understand if Windows is actually doing anything to the output at all before sending it to my headphones.
Thank you

Show your signal path first…

In non-exclusive mode, the output audio format (i.e. what is sent to the DAC) is fixed, regardless of the source format. This is done so that multiple concurrent audio sources can be played simultaneously by mixing them together. So, if source format is the same as the output format, and if nothing else is playing at the same time, no processing is done.

1 Like

Thank you for your help Marian.
Here’s a screenshot of my chain.


As Marian said, in the mode you’ve configured Roon, Windows resamples all audio to whatever it’s set to - that’s why you “only” get the high quality green light, rather than the blue bit perfect one.
If it’s more comfortable for you and you can’t hear a difference to exclusive mode, stop worrying and go ahead, but if you do hear a difference you probably need to adjust your habits…

Unless formats match. I guess Roon is just defensive and doesn’t want to assume anything. If you expect to hear a difference because of the lights, you most probably will. I did however verify that what the driver receives is identical to the source when the two conditions are met.

1 Like

@Marian_Trandafir, I’m seeing it the same way, actually

1 Like

All settings are default. My screenshot was simply with Exclusive mode switched off and no other audio sources active.

I was curious if Windows actually did anything at all in this situation or just left the audio alone.

I am hoping that without Exclusive mode, Windows doesn’t downscale higher resolution audio to match my ‘shared audio’ settings in the Sound control panel of 16 bit 44.1 kHz?

If I’m working and listening to music on my pc, I don’t want to have to switch Roon off every time I need to listen to something that’s not Roon. I understand that exclusive mode is there for bit perfect listening and I just wanted to get as close to that as possible while retaining the freedom to change audio sources.

Windows will convert anything that doesn’t match the sound settings to that format, so in this particular case, it will down-sample. You can set the format to the highest rate and bit depth of your sources so that Windows will only up-sample if needed.

I’m doing the same. I configured Roon to use ASIO, which does use the device in exclusive mode under the covers. As long as I stop Roon playback before using other sources, I don’t have a problem with audio.

Correction: I need to stop playback and exit Roon before the device can be used by other apps. A bit inconvenient, but I can resume where I left off upon restart.

Thank you. That’s what I’m going to have to do too then if I don’t want Windows messing with the sound.
If I set the sound settings to 24 bit 192 kHz and keep Exclusive mode off, Windows will then upscale all audio tracks that are not 192 kHz and I don’t want that either.

Hmm. I thought that there is a 10 sec delay before devices are released back to the system after playback stops. Of course, individual audio drivers may have different interactions with Roon, the EVGA NU drivers do.

It is up the app to release devices. Does Roon do that? I guess not, at least not within a few minutes.

Tested things with DAC S.M.S.L. M300MkII connected to core via USB in exclusive mode and XMOS ASIO driver .

Started Qobuz, which is configured to use USB ASIO also, while Roon is playing and as soon as Qobuz had launched Roon playback stopped and Qobuz took over the DAC.
Roon does not take over again on switching focus, unless I close Qobuz.

It’s the same when doing it the other way around with Qobuz playing and starting Roon. There, I have to close Roon to use Qobuz again.

Thank you. That’s what I’m going to have to do too then if I don’t want Windows messing with the sound.

Thank you.

I’ve never had to close Roon to release audio. Just stopping playback releases exclusive mode and I could happily use other apps inbetween music listening.