Double Upsampling (up and then down indeed)


(Isiah Lau) #1

Folks, today I tried something and very astonished by the result.

This is double sampling, please see the screens. The result is crazy. Please try by yourself and share your feeling too.




(Jussi Laako (Signalyst)) #2

It is not double upsampling, you upsample first in Roon to higher rate and then downsample in HQPlayer back to lower rate. The part you are doing with HQPlayer here is totally pointless and doesn’t do anything useful, it just burns CPU cycles for no reason…

Just use either Roon’s DSP, or HQPlayer’s DSP, but don’t combine the two…


(Isiah Lau) #3

Jussi, thanks, you are correct about it goes to higher and then lower. But I can’t feed upsampling to 705.6 at Roon at first step if not going through HQplayer.

If I just use either Roon DSP OR HQplayer upsampling, I can’t produce the equal sound quality.

It is not pointless, truly, at least the end result is not pointless. The sound quality is significantly higher. May be its only my system? Jussi (I know you are the HQplayer developer). Can you try once and share too? I encourage other users to try and comment too.


(Jussi Laako (Signalyst)) #4

Why would you want to, since you DAC seems to be able to accept only 352.8?

No, I don’t want to touch Roon’s DSP. And I look this from technical point of view, I know what happens without trying it, it is just mathematics.


(Jussi Laako (Signalyst)) #5

Problem is that in Roon you first generate twice the number of samples needed, and then next in HQPlayer you throw half of the samples away. That is redundant work…


(Andrew Cox) #6

With the Volume Control in HQ Player set to zero, you have no headroom and the output has been limited 20 times. I don’t know if the resultant distortion is audible, but it seems undesirable.


(Mr Fix It ) #7

If the op thinks it sounds better to his ears who are we to argue. Regardless of how crazy it sounds, or seems to be wasteful of cpu resources and processing power, he is entitled to run his data path how he likes and if that sounds better to his ears then so be it.

I don’t have HQP to try it but nothing is stopping those who do from trying it…who knows what one might like if you don’t try.


(Isiah Lau) #8

I am very sure it sounds different. Just like many other arguments in audiophile world, theory vs reality. I encourage anyone with HQplayer to try first and then comment.


(Isiah Lau) #9

Thanks for your observation. How do I correct it?


(Andrew Cox) #10

Set a range for the volume control in Settings (vol min and vol max). I use -16 and 0. Experiment with volume settings until the Limited counter (in the TIme box) in the main window no longer increments. I’d suggest starting at -2dB and reducing by one dB as necessary until the Limited counter stops counting. Limited output is also indicated visually by the red outline of the volume knob, which should turn black when limiting stops.

I use -8 dB in HQ Player but I am also convolving a room EQ file. You should be fine with -2 or -3 dB.

If you continue to use both Roon and HQ Player DSP I would also suggest adding -2 dB of headroom in Roon using the Headroom tool.

This article.explains intersample peaks and how providing headroom avoids them.


(Jussi Laako (Signalyst)) #11

If it is limiting in HQPlayer, it has likely clipped already in Roon’s output too. Does Roon indicate clippinging in the output somehow?

I notice Eq being active in the Roon pipeline, if there’s a boost at some frequency there, corresponding amount of headroom plus some extra should probably be set at Roon side to avoid Roon’s output from clipping. Clips from Eq boosts are particularly nasty, because it doesn’t happen as obviously if there’s a notch boost, because it requires content to happen to have 0 dBFS at that frequency before it is noticed. And that doesn’t usually happen immediately.

I’ve tried to make it as inaudible as possible by using a low distortion soft-knee limiter. That’s why there is fairly strong visual indication of the action…


(Isiah Lau) #12

Thanks Jussi I can’t see any clipping indicator in Roon. Comparatively it’s very useful feature in HQPlayer.

I’ll continue my experiment later today. Not at home now.


(Andrew Cox) #13

The signal path light will flash red when Roon is limiting or clipping.


(Isiah Lau) #14

Cool I have never seen it happening, probably Roon already self manage it pretty well?


(Isiah Lau) #15

Answer to myself, that flash red light on signal path light is off by default. Once turn it on I can see clipping if headroom is over -5


(Andrew Cox) #16

Well done. I thought there was a switch but couldn’t remember where it is.

With the clipping and limiting under control you’ll be hearing a higher fidelity signal.