Downgrade Roon Server from 2020-07-15

I was running an older version of Roon Server (2019-06-09). I recently updated to 2020-07-15 and I cannot get any of my devices to play music, iPhone or Airport Express. I can see the server, connect, select a song, etc., but when I press play nothing comes out. Any thoughts?

Is there any way to get an older qpkg and downgrade to see if that works?



There is no reason the latest build shouldn’t work

Maybe post details of your setup so someone can help

Sorry about that I realized that I should have included. Details below. I know I don’t meet minimum requirements, but I have been able to get it to work before.

After my original post I also downloaded Roon for Windows and lo and behold, it worked. Audio is streaming.

And even more weird, after trying to music to play on my iPhone dozens of times, I played it through Windows and now it’s working on my iPhone. There were no changes in my Roon iOS settings.

Literally, would not work on my iPhone. Installed Roon for Windows. Played one song on Windows. Tried again the iPhone and it worked. So weird.


Core Machine (Operating system/System info/Roon build number)

Celeron CPU N3060 @1.60GHz

Version : 1.7 (build 710) stable
QPKG-Version : 2020-07-15

Roonserver is running on SanDisk SDCZ880-128G-G46 Extreme PRO 128GB USB 3.1

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Netgear 16-Port Gigabit Ethernet Unmanaged Switch, GS316
Netgear Orbi RBK50 Router
Netgear Orbi RBS50 Satellites (Qty 2)

QNAP and all Orbis hardwired to switch

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Dell PC
iPhone X - Firmware 13.6
Apple Airport Express A1392 - Connected via wifi - Firmware 8 or 8.1 (78999.12)

What type of files are you trying to play ? AAC, ALAC, FLAC?

Is your iPhone also on B710? If not you need to update it too.

If Roon is running on Qnap 4.5.1 then there is a problem with the codecs - aac support is removed. This thread explains and offers a solution

Ahh. Interesting. I could very well have been trying AACs. Let me dig into that and test. Could have been a total coincidence that the most recent file I tried to test with was something else.


They could have been AACs, so I’m going to check the thread indicated below.

Makes sense as QNAP pulled support for ffmpeg transcoding on their bundled version. You can get around it I believe several posts on here how to do it.