Downgraded from 2.0 to 1.8 on Synology and cant see music folder

Deleted my 2.0 Synology package (using Package Manager) and installed 1.8 Legacy. It all went well and the core comes up fine.

The problem is 1.8 Legacy gets confused trying to find my music folder. I see two problems that might have something to do with it:

  1. I see lots of access denied errors for the path /var/packages/RoonServer/target/roonmnt which no longer exists when using 1.8 Legacy. The new path is /var/packages/RoonServerLegacy. Because of this I see lots of errors like:
11/02 02:06:04 Critical: [broker/filebrowser] [nassharemaker] exception in rebuild, text: System.IO.DirectoryNotFoundException: Could not find a part of the path '/var/packages/RoonServer/target/roonmnt'.

11/02 02:06:00 Critical: [broker/filebrowser/nasutils] constructor failed: : System.UnauthorizedAccessException: Access to the path '/var/packages/RoonServer/target/roonmnt' is denied.
  1. Another issue is a previous NAS shows up in this log entry:

Debug: [broker/filebrowser/nas] init mounts, id: 21B0TERE8AYC2, title: Synology DS412+, subtitle: DiskStation, 21B0TERE8AYC2, DSM 7.1, mountdir: /var/packages/RoonServer/target/roonmnt

The DS412+ was a NAS I had ages ago, yet somehow it still appears. This isn’t something set locally on the newer NAS (I don’t think) - I assume this comes from some database over at RoonLabs, but again I can’t be certain.

If anyone can shed any light here It’d be much appreciated. I can’t add any music folders to Roon as it sits. It just tries to force me to choose folders from a non-existent path.

Same here. When I try to add a shared folder I see a non existent subfolder “wogenkind” (= NAS name) > “Synology DS716+” and “Error loading folder. Not found”. There must be some “memory” in Roon pointing to that no longer existing folder. Please, provide a workaround, since it’s no fun running Roon w/o music folders - only QOBUZ with lipstick :-).

TIA, Franz-Josef

1 Like

I searched high and low for that name it’s using, can’t find it. In my case it’s actually my old NAS I no longer have (can’t even run Roon on a DS412+).

Hi Joe, just had a conversation with @crieke, he fixed the 1.8 installer, and now everything ist back to working. Hope this works for you, too! If it does, please mark this thread as solved :slight_smile: .

1 Like

Hi Franz, thanks so much - it worked perfectly. Marking as closed.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.