Downgrading DSD Signal and performance problems

Roon Core Machine

Lenovo Thinkpad Yoga Intel I7 16GB Roon Core. 200GB of 512GB SSD used. Roon Core 1.8 (build 936) stable (64 bit).

Networking Gear & Setup Details

1000/100Mbps incoming fiber. Asus ROG 11000 Router w basic Firewall. Supra Cat 8 Cable to HP 10 Gbps Switch. Supra Cat 8 Cable to Media converter box. Fiber to Melco S100 switch. Luna Cables Mauve ethernet cable to HifiRose 150B Streamer.

Synology DS412 NAS via Supra CAT 8 to HP 10Gbps swtich…
Using Qobus, Tidal, Spotify and locally stored files on Synology NAS

Connected Audio Devices

HifiRose 150B via AudioQuest Earth ASE/EBU or via Curious Cables Original USB to PS Audio Direct Stream DAC. Direct Stream DAC via Omega Audio Concept Nano XLR (Balanced) to MBL N51 Integrated Amplifier. MBL N51 via Omega Audio Concept Nano spreaker cables to Martin Logan Impressions 11A.

Number of Tracks in Library

1500 tracks locally stored on NAS. Qobus, Tidal, Spotify.

Description of Issue

  1. Roon is converting the signal from DSD to a lower bitrate PCM signal (DSD ->352,8kHz->176,4kHz

  2. Bit rate conversion downgrade 64 bit Float to 32 bit

  3. This happens before the signal reach the Streamer.

  4. After about 30 seconds the track stopes and is dropped from Roon.

  5. On Qobus playing 24bit /192kHz tracks sometimes (intermittent) the track stops and sometime no sound is played.

Error detection measures taken:

  1. Check performance monitor on NAS with no abnormalities
  2. Check performance monitor on Core with high utilization on processor (up to 80% peaks) but no abnormalities
  3. Check to play in HifiRose app with no similar problems.

How do I solve this?

Kind regards

Reinhold

Check the settings on your streamer. Roon will not send DSD or HighRes PCM if the streamer doesn’t announce those formats as supported. Contact HiFi Rose if you need help to setup your streamer or post questions in their forum.

2 Likes

No. That’s not it. That was the first thing I did. When playing without r
Roon directly on the streamer I have no such problems.

Any other ideas?

Note: Playing stuff on your streamer, actually player in that use case, is not the same as using it as a streamer.

Check your Roon settings if you think it’s worth the time because the settings on your streamer are right:

1 Like

Hi @Reinhold_Konnander,

Thank you bringing this issue to our attention. I’m sorry to hear that there’s some unwanted conversion going on in your chain, and we’d be happy to help pin down the issue.

If you don’t mind, would you please share a screenshot of your signal path?

There are a few reasons why Roon will convert DSD content to PCM. As @BlackJack pointed out, Roon requires the streamer to present itself as DSD-capable, otherwise Roon will automatically convert the file to PCM during playback. Many users resolve the issue by confirming DSD playback is exclusively enabled in the product’s setup interface.

Another possibility is that there’s some digital processing going on which requires conversion to PCM. If you have any volume leveling or crossfade enabled in your chain, please disable these stages for now. Also confirm that any “DSP Volume Controls” are disabled on your streamer.

I would also recommend you reboot your Core and also logout/login of Qobuz in Settings → Services. This will help ensure replicable and stable conditions as we troubleshoot further. We’ll keep an eye out for your response and work from there!

3 Likes

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.