Download of 1.8 does not work

IPad download to 1.8 did work. Download to NUC 7i5 starts Bit does not finish. Result: No roon anymore. Are there similar experiences? Any Solution?

NUC core seemed to update itself. Android phone updated ok but Fire 10 is stuffed. It will neither open not uninstall.

Edit: managed to uninstall and reinstall. Now it works :+1:

try again… Roon on iPad comes from Apple, not from us.

Dear Danny, the iPad download does work. Its now updated and in a next step I starten the update on the Roon Core but this doesńt finish. Ist stops in the the middle and as a result I cannot use Roon anymore. Best,Arndt

Are you running ROCK or Nucleus? if so, try the reinstall button from the web ui.

Same here.
Ipad download successful, but then downloading core (Nucleus) update got totally stuck.
It’s been like this for several hours.
I tried to start again, delete Ipad app, etc…Nothing works

Same advice about reinstall button for anyone having this issue.

4 posts were split to a new topic: Can’t update Lampizator Core to 1.8

Rock on NUC7i5. Turned the rock core on and off - no change. Installed the app again- no change. The App updates easily to 1.8. but the update process for the core stops always at about the middle.

Same for me. Roon server on a i5 NUC on Linux mint.
No progress for some hours.

Mine is looking exactly the same- for hours meanwhile

Same for me too. Updated iPad Pro to 1.8 with no problems.
Updating Roon Server on my late 2018 Mac Mini Pro seems to have frozen (downloading for 3 hours).
I have no problems with internet and network.
I have a similar screen to Thorsten_Hagenberger above

Now I tried to start the update from my Mac instead of iphone and the update was finished successfull after a few seconds. It seems to be a problem of the ios clients.

Solved after rebooting Nucleus fro Web UI.

I’m having NO luck trying to install Roon 1.8. I have a 2015 Mac Powerbook. I’ve already updated the app on my phone and iPad. But it fails after downloading (on install).

I have a life time subscription, so I’m really most unimpressed.

1 Like

Try downloading the OS X installer from Roon Software Downloads - PC, Mac, Linux, Android & iOS | Get it Now

And replacing your existing install.

Auto update didn’t work for me either but worked this way.

Run it from the application dir once installed rather than your old launcher icon

I have a brand new Mac Mini and when I try to download the update the scroll bar gets halfway through the down load then fails and says problem accessing the update?


i had the same problem, but after restarting my roon core (the sonic transporter — not the roon software), it automatically resumed and completed downloading when i next launched the ios app.

my Core update on Mac mini Pro Roon Server froze. iPad was updated first to 1.8
I solved the problem by force shut down of the Mac mini and started the core upgrade process again.
Pity about tracks in Album view no longer show Playlists they are linked to

I had the same problem. Force shutdown the Mac mini. Turn on the Mini and restart the Core upgrade process