Download of Roon 1.7 (build 500) fails

The download (and installation) of the update to Roon version 1.7 (build 500) fails. Message returned: “There was an error checking for an update.”

Roon Core running on Windows 10, 64 bit.

Is there a work around available?

Restart Roon

1 Like

Already tried that with the exact same result.

Please remove the solution tag until the problem is actually solved. Thank you.

I am having the exact same problem. However Roon is still working on the “core” machine but I can no longer use my laptop as a Roon control.

Do you have any antivirus or firewall on your core machine ? If so: Disable it > Restart the Core > Let it update once more

I will try this and let you know if it worked. In the mean time please remove the solution check mark until the problem is solved. Thank you.

Better option - download build form here - > close roon > install downloaded package
Your DB will be intact (no need to uninstall your old app)

and what about a link for Mac? or iPhone or android ??

I copied link from here -

and for iPads ?

@antonio_uvalle — iOS should be available soon:

Thank you. This appears to be working but since I have a very, very large database the database update is taking a long time. I will let you know when the database update is complete and Roon is up and running.

Perfect, thank you for response.

2 posts were merged into an existing topic: Where is 1.7 for iOS? [Update will be available soon]

Okay so the database update completed and I now have a fully working Roon version 1.7!

Thanks again for your help. And yes, now you can check the “solution” box. :grin:

1 Like

Glad to hear things are working now, @Jazzfan_NJ! Your patience has been appreciated :slightly_smiling_face:

If anything comes up please feel free to let us know in a new thread.