Downloading and Re-Installing problems


Today I had to reboot my RPi with Ropieee and I noticed that it was taking a long time to come back.

When I checked it was hanging in the Phase 3 “checking updates”. Eventually after 15 minutes it came up but Roon wasn’t recognizing the zone anymore.

I tried rebooting over and over, and had the same issue. In a couple of occasions Roon found the RPi but when I tried to play I got an error and the zone wasn’t available anymore.

I decided to download again Ropieee but the download is taking a lot of time. The ETA was around 9 hours and now I still have 6h45 minutes to go (this for the compressed version)

I looked around and discovered that I still had the older version of Ropieee so I re-flashed the card with it but now the process is stuck for the last hour at

… Touchscreen detected …

… Installing touchscreen software …

I checked and it seems the RPi is downloading data but a super slow speed.

Raspberry Pi 3b with IQ audio Dac Pro and RPi touchscreen

Ropieee software version installed before the first reboot was 4.002

Any idea how I can get it back?

it seems was a problem with the server because all of sudden it downloaded it very quickly.
However I am still having issues.
The RPi disappears from the available zones if, for example, I change settings in the device set up in Roon. Or if I reboot the RPi sometimes it doesn’t come up.
I have another RPi with IQAudio Dac that work flawlessly, only difference is that it doesn’t have the touch screen.
Could be the IQ Dac being busted? or the motherboard? How I can troubleshoot the problem?


It could be a damaged micro SD, or if you are on WiFi that might also be the issue. Try connecting via Ethernet, if that fails try a different micro SD.

thanks, I am connected via ethernet, will try with a ne SD

I am still having issues.
I had it running for 3 days straight without issues, the RPi was rebooting every night at 3am without problem. Today my daughter asked me to change the color of the clock to a custom color.
I did the change, then I was asked to reboot. After the reboot Roon wasn’t seeing the RPi anymore. I rebooted again and Roon was then able to see the zone again and I was seeing the screen of the RPi showing the track but when I press play I get Failed to Open Audio device.
I tried to restart the core and while it still see the RPi and the roon extension is showing the correct track I still get Failed to Open Audio device.
After having rebooted it 3 times it finally worked again.
I don’t think it is related to the SD as I don’t get any system error that I should get in a case like this.
Instead when the RPi is not seen by Roon I get the usual message on the RPi

Is the DAC turned on?
Is the Ropieee Remote Control extension enabled in Roon?
Is the correct zone configured in Ropieee?

Once the RPi is working I tried to shut down Roon without touching the RPi, once Roon comes up I get the extension to show the correct track but again Failed to Open Audio device.

Now the Rpi, just rebooted itself… I wonder if the Pi is busted