Downloading files takes longer with Roon running

Roon Core Machine

Apple MacBook Pro (15" 2017)
Cataline 10.15.7
3.1 GHz Quad-Core Intel Core i7
16GB 2133 MHz LPDDR3

Networking Gear & Setup Details

Virgin Media Hub 3 connected to laptop via ethernet.

Connected Audio Devices

Raspberry Pi 4b with Allo BOSS DAC connected to router via ethernet & to analogue amp via standard phono.

Number of Tracks in Library

25,328. (This is in settings. I would’ve expected to find it at the top of “Tracks” the way the album total is at the top of “Albums”.)

Description of Issue

I was downloading a ton of stuff from my local Dropbox folder on my desktop to my Roon library which is on an external hard drive. It started off telling me something like 19 minutes, then, when I checked back it was saying something like 55 minutes! Roon was chugging away with the little loading icon spinning.

On a whim, I decided to quit Roon & suddenly the copy time dropped to something like 6 minutes & in fact didn’t take nearly that long to complete.

So, no major problem. Just wondering why Roon would cause the copy time to become so extended? It’s almost as though it’s interacting with the Mac OS & asking the system to hold up while it processes what it’s been given, rather than just scanning & reacting to what it finds.

Thanks. :slight_smile:

If they are new tracks to Roon then it is probably discovering the new tracks and doing all the meta data updates. You disable roon storage then copy then enable again.
This is taken from the roon help on moving storage location

  1. For performance reasons, if you are adding a large amount of music (1000’s of tracks), quit Roon (or stop RoonServer on Nucleus). The best experience will come from letting Roon look at the folders when the files have settled.

  2. Move/Copy the files to the new location

  3. If you stopped Roon in Step 3, start it again.


Perfect, thanks! :slight_smile:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.