Drag feature No longer working when using iPhone Mobile device, it shuts down the app

Roon Core Machine

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Can re-arrange my Playlists on my iPhone any more. Used to work fine, no when I click on the drag dots, it closes down the app immediately. I can edit Playlists via my iPad, just fine. Why did this stop being avaialble for iPhone, or my phone? Makes no sense. Please advise. Thanks, John H

I Meant to say " I Cannot, edit playlists on my iPhone any longer"

Hey @John_Huffman,

Are you still running into this issue? If you uninstall Roon on your mobile device and reinstall, does it still happen?

Hi Ben,

That did not fix it. Thx

I‘m seeing the same behaviour.
Build 1180, Iphone 13mini.

Hey @Kopftelefon and @John_Huffman,

We’ll need a set of manual logs from the iOS device affected. Please use the directions found here, recreate the issue a few times and send over a set of logs to our File Uploader.

Hey @benjamin ,
you got a nice set of logs for Christmas. :wink: Please let me know if I did it right.

Happy Holidays :christmas_tree:

1 Like

Same here when trying to move songs up or down in playlist. Roon crashes. iPhone xs. Latest version of Roon and iOS

Thank you for sending logs over @Kopftelefon! I will be bring this issue to our team tomorrow to learn more.

In the meantime, are you able to test this issue out further by attempting to move around tracks from your local library VS streaming services? Does it happen with all file types? Or, are you only seeing this happen with hi-res files?

I will follow up with more information after our discussion tomorrow :pray:

Hey @benjamin.
I made a playlist with different content (local and remote, different file types) to test.
Result: it doesn’t matter if the files are local or on a streaming service, hi-res or mp3. As soon as I try to drag an entry around by the six dots to the left, roon remote crashes. This only happens on my iphone, it works as intended on an ipad mini.

I’m seeing the same thing. Mentioned here: Crashing Roon Remote on Android

Thanks, I was just trying to reanimate an old android device to test further. :wink:
Long press to select works fine on iOS. Trying to drag a file around instantly closes the app, without any freezes.

Just tried this exactly same result instant crash. IOS 16.2 iPhone SE2020. On Android it just makes the app freeze and unresponsive.

Hey everyone,

I wanted to give you a quick update. We’ve found the regression in this issue and the fix is waiting for release :+1:

Thank you for your patience while we get this cleared up!

1 Like

Ben, thanks so much. I knew it couldn’t just be me! Thx to those who sent logs

It will be great have this function back!

John H. HAPPY NEW YEAR!!!

2 Likes

This is fixed for me in build 1197. Thanks, guys.

Still not working for me. IPhone build 1193. Mac OS 1193.

Same problem as before. I think i have the latest version