Dragonfly Cobalt not showing up as Roon tested and missing icon

Roon Core Machine

Include your operating system and machine info (Model, CPU, RAM)

Networking Gear & Setup Details

Your network gear (model of routers/switches) and if on WiFi/Ethernet

Connected Audio Devices

Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.)

Number of Tracks in Library

Tell us how large your music library is, eg. “30,000 tracks”

Description of Issue

Tell us about the problem you’re having in as much detail as possible. Screenshots are always appreciated!

Hello, I have a Dragonfly Cobalt. Before I was able to see the icon correctly, and I think it showed up under Roon Tested in the audio settings. But, now it’s in the “This Mac” and labelled Core Audio. I’m not sure why. Any thoughts? Thank you

Post in the support area.

I moved the post to Support.

Thank you!.. First time here.

Don’t be lazy Ged. You can move post yourself :stuck_out_tongue:

@Ryan_Boatright Welcome on board.

Have you tried disconnecting the Cobalt, restarting your Core and then plug the Cobalt back in? Yes, it should show up under Audio as Audioquest and not anything else. At least that’s how it works for me.

1 Like

Thanks, just tried that. Disconnecting Core, restarting everything, etc. Nothing works. Here is an image

1 Like

Hey @Ryan_Boatright

Thank you for getting in touch, and welcome to Community! We’re happy to have you but sorry to see that it was an issue that prompted your first post. We’d be happy to help figure this out!

So we can better assist you, please provide a brief description of your current setup using the template I added to your report above as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

@RBO, started you in the correct direction but your Core appears to be on ROCK, not your Mac. Please disconnect your Dragonfly from the Mac, restart that machine, then reconnect your Dragonfly.

Also, did you happen to use any of Apple’s cloning tools when setting up Roon on that machine?

We’ll be watching for your reply and get back to you as soon as we can.


Silly question but have you clicked on the gear in the grey box and re-identified the device?


It does seem that one of your outs on the Mac was accidentally renamed as the Dragonfly. Shortly after your last post the Dragonfly looks like it was seen by Roon. Can you please update us on your current status? If you’re still having trouble and need help we’re happy to lend a hand! Thanks!

Thank you all. I have two cores. One ROCK at home and the other on my MacBook. I move between the two. I’ve tried disconnecting and restarting, etc. I didn’t know I could « ré-initialize » a device. I’ll try that. I don’t think I misidentified a device. I also have a chorde mojo 2 which shows up in the same zone as the dragonfly but with the good icon. I’ll take another look at all and let you know. Thank you!

When you play to it, does it show as Dragonfly in your signal path?

I remember I had a similar issues when Roon could not find the iPad icon. What I did was delete the remote, reinstalled it and got it to find the icon for the iPad.

It really seems to be a bug. I’ve tried disconnecting the core, removing the DragonFly, re-connecting, everything. The icon is missing.