Dropouts when Android device is used as a remote

I never had this issue until the 401 release. Now I have severe dropouts.

Setup : ROCK on NUC, and SoTM via USB to Marantz DAC. Connection all wired.
I only use Android for Control via WiFi. Never had dropouts… until the release of 401. Both my Huawei phone, and my Samsung Tablet are basically useless controlling now this setup since they just generate dropouts (also at standard CD sample rate)
Using a Windows10 PC is solid as a rock: not a single dropout with hours of playback at various sample rates.
I even changed the firmware of the SoTM, but after hours of testing different setups the only conclusion is:
Using Android to control my setup generates dropouts.

The whole reason for me to use ROCK was not to be dependent on my Win10 PC for listening to my music, using tablet or mobile as controller.
Roon rocks, I love it, I expect this to get resolved, and I hope it gets resolved soon.

Small update:

  • even on Win10 now I get some occasional dropouts (few after several hours)
    Pausing playback for a few seconds and then continue fixes this

  • I tried the old Android version (1.6 release of January) but that gave the similar dropouts as the latest 401 build of February (of course Roon Core still remained 401)

Hello @Andre_Klap,

Thanks for contacting us regarding this issue. Since the dropouts are occurring both on your Android devices and your Windows 10 PC I am inclined to say that this is a networking issue somewhere along the line. Let’s try to simplify things a bit:

  • What is the behavior if you connect your Marantz DAC to the ROCK directly via USB (bypassing the SoTM) and using an Android as the control point, do you still experience dropouts?

  • What is your network setup like? Is the ROCK plugged in directly to your router or are you making use of any switches/range extenders/powerline adapters?

  • Have you tried rebooting the ROCK yet?

  • Does this issue occur for both Local Content and Streaming content or just one and not the other?


Hi Noris,

Thanks for reaching out. In the mean time I found that Win10 as Control and as Audio device didn’t give dropouts. That got me thinking, and I started a structured approach:

  • Win10 control + Win10 Audio = no dropouts
  • Win10 control + Squeezebox Touch = no dropouts
  • Android control + Squeezebox Touch = no dropouts
    So I also concluded that it is linked to the network setup or the SoTM firmware and setup.

What I did since then is:

  1. ASUS Router enable the “Enable Multicast Routing” option
  2. on a new SDCard (98 MB/sec, class 10) I loaded the latest SoTM firmware, installed it and set the buffer to 0.40 sec. (I had this SW also before with dropouts, but on a slower SD card)

Results: Yesterday evening I only managed to listen (via Android control) for ~10 mins but without audio-dropouts (with 96k-24bit audio).
I will need to do more testing but this is looking promising.

To answer your questions:

  • Marantz DAC directly to NUC: not tested, difficult to do quickly. will do as a last resort
  • No extenders or powerline, but some switches in the path from NUC --> SoTM
    ( I plan to optimize the setup next month and then will also try to reduce #switches in the path)
  • rebooted ROCK : yes , was 1 of the first things to do: reboot ROCK, SoTM, Router
  • I don’t have streaming services like Tidal or Qobuz, all my music is on a NAS on the network

After doing more testing I will report back.

As promised I did further testing and I’m happy to report that the dropouts have gone with these 2 changes:

  • new 0.4.56 firmware in the SoTM on a very fast SD card
  • ASUS Router enable the “Enable Multicast Routing” option

I even went back and disabled the option on the router and still no dropouts, so the firmware update on the SoTM did the trick.
(Router option is now enabled again following your netwerk optimization webpage).

I’m enjoying music again.
Thanks for the support.

1 Like

Hi @Andre_Klap,

Great to hear that the dropouts have been resolved with this changes!
Thanks again for contacting us regarding this issue and I wish you a pleasant listening session :headphones:

– Noris

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.