Dropouts with All Sources

Roon Core Machine

Intel NUC 10i7FNH 16 gig RAM

Networking Gear & Setup Details

QNAP TS451+ >>AA

Intel NUC10i7FNH >>AA

AA : TP-link 8 port Gigabit Switch (TL-SG108)>>Sagecom Fast 5250 Home Hub 2000 Router>>TP-Link 16 Port Gigabit Ethernet Networ**k Switch, (**TL-SG116)>>Bluesound Node 2i

Connected Audio Devices

IPad for control via wireless network,
Audiocontrol Maestro X9 (usually << via the Bluesound Node 2i),
Yulong Sabre D18>>McIntosh MXA60

Number of Tracks in Library


Description of Issue

Dropouts started around three weeks ago, system was stable prior to.
Dropouts lasting a split second up to a second with return to track, or a complete pause that can be restarted using control app via Ipad.
There are usually two, up to five dropouts per album. It makes no difference if it’s radio, or content from NAS, nor does it matter the file type, or whether it’s 16 bit 41,000 Hz or 24 bit 96,000 Hz
Resets/restarts of all equipment do not solve issue.
Also note that Node 2i plays flawlessly without Roon.

Somewhat like you, I’m experiencing pauses either between or during songs which require hitting the play icon to resume playback. I am using a NUC/ROCK NUC10i3FNK1. Three Roon endpoints all RPI based running the latest stable version of RoPieee. Earlier today I was unable to play beyond the first song in the “Pop Rock” genre without hitting play after every song.
I don’t think its a home network issue. Perhaps it’s just a temporary glitch. If not I have no doubt the Roon team will find the cure.

Hey John,
Thanks for the note. I think it may be the NUC, but we’ll see.

Thanks Ed.
Yes of course it could be something on my end. I rebooted the router on my eero Pro mesh system and Roon behavior appears to have returned to normal. I’m new to NUC. Previously my core resided on a PC. So far, in the month or so I’ve used the NUC it seems to be as reliable as an anvil. More stable and less fussy than the PC if maybe not quite as snappy. If the problem returns I try power cycling the NUC.
Thanks again,

Tidal is down in the USA, maybe that is affecting?

My set-up is wired, and had been stable. Changed out cat5 cables, bypassed a switch, power cycled the world, and still no joy.

Thanks Late nighter,
I agree, the behavior does seem to point to Tidal streaming encountering some irregularities. Still having some hiccups. For me it works but has glitches where it stalls. Usually it responds to another press of play, but some times the Roon remote (iPhone or PC) becomes non responsive. I’m headed off to power cycle the NUC now just to see if that resolves anything.

Tidal, Qobuz and radio all are being very strange for me:

  • radio: will play for a minute or two max and then cuts out
  • tidal and qobuz: will start playing a track and then will stop or suggest it is still playing but timer not moving and whole thing is not playing any sound.

Anyone else having this? Is it linked to the AWS outage etc? I’m based in the UK.

Problem solved, fiddled with SMB settings. The YouTube video at the link below might help anyone else with this problem.

I spoke too soon, dropouts still occurring.

I still have drop-outs, about the same frequency as before my “problem solved” post. Help!

Problem NOT SOLVED. Can someone from support give me a hand, please?

Ed, I’m not support, but I’m chasing the same problem. I have an extremely tentative hypothesis that this is a Roon bug, a race condition, triggered by a change in status of an endpoint, but also by unexpected network resource unavailability (perhaps due to LAN or WAN issues). That is, Roon Core notices something in the local network which throws it into a kind of hissy fit of re-checking everything, and as part of that it calls out to some external Roon resource, which fails to accept the connection. Which failure, if the timing is just right, will stop the currently streaming track. So, very hard to reproduce, and probably sensitive to your local network setup.

Hey Ed, we’ve got an article on troubleshooting audio dropouts at the link below. Can you run through it and let me know what you’ve tried so far?

1 Like

I got Roon in July of last year. I had about 4 months of solid performance without any dropouts. Dropouts are intermittent now. I’ve changed cables, relocated the NUC, and even tried using a second NAS, and still dropouts. I don’t know how to trouble shoot my network using logs, so you’ll have to help with that.

Thanks for getting back to me,


Still having dropouts, it must be the NUC, the Bell router/modem, or the TP-Link mesh. I get the occasional message that the files are loading too slowly when drop-outs occur, but not usually.