Dropping track in Roon

Core Machine (Operating system/System info/Roon build number)

WIN 10 Intel i7 32gb ram wired to hub
Roon version 1.7 build 667

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

BT Ultrafast fibre - BT home hub.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Bluesound node 2i. Connected to hub via ethernet hard wired cable

Description Of Issue

Dropouts. When playing an album from Qobuz it will stall on a certain track. Example from today

Artist Wizkid. Album Made in Lagos. Roon refuses to play the track Gyrate. Roon will play the first 10 seconds then quits and displays the message “Qobuz is loading slowly blah blah”. When it does this I can try the track endless times with the same result.
This will happen frequently with random albums, and it always does the same. It will come to a certain point then Roon will fail consistently

So I will switch to the BluOS controller which plays the track perfectly - looping any track that fails on Roon if I want it to without a hitch. The only change is the software - BluOS plays it perfectly through the Node2i where Roon fails. I only subscribed to Roon because I don;t like the BluOS software. However it’s pointless if Roon won’t stream what BluOS does without problem.

Welcome to the community. While we’re waiting for a member of the Support team to come along and respond directly, I just thought I’d ask whether your Core machine is also connected via ethernet?

I ask, because I’ve just played this track for myself, and had no problems (in fact I was also playing other tracks simultaneously to other Roon Zones).

I suspect that there’s a networking issue lying at the root of your trouble, so the more detail that you can give about your network setup, the better the Roon Support team will be able to help you, I believe.


yes it (core machine) is connected via ethernet. However, even if it wasn’t that isn’t the issue. How can the bluesound OS successfully stream what Roon cannot? Something in Roon is going wrong - almost like it holds the track in a cache and because it experienced a problem last time it’s just going to refuse to play and fail at the same point forever.


Roon unpacks the flac file in the server then sends the pcm file to the endpoint using RAAT. The bluos app sends the flac and gets the device to unpack it.
So the usage is different and can lead to issues.
I would try rebooting everything including the network equipment.

thanks - everything gets rebooted each time it happens. I’m guessing there is some unpacking issue which never gets resolved.

and I just noticed. I stream Radio 6 whilst I work. Roon usually stops after a couple of hours, and I just restart it. Streaming live radio through the BlueOS app it hasn’t stopped once since 6am. 5 hours continuous.

Hi @Richard_Slater,

Welcome to the forum! Can you please confirm if multiple audio zones are affected by this behavior or just the Node 2i?

If you try to play to your Window’s System Output zone (the internal speakers), do you notice any issues occur for that zone ?

This test can allow us to separate if the issue is with the stream arriving to the Core or the stream arriving to the Node.

Thanks Noris
It’s just the node2i and no other zone. I don’t notice any issues with local playback. This, plus the consistent behaviour of bluOS leads me to suspect something wrong with Windows to node 2i transmission.
I have worked out how to prompt this behaviour by selecting a different album in Qobuz, then going backwards through the track list. After several tracks, it will fail. The Bluesound app doesn’t do this. Also the bluOS app is a lot faster to respond

Hi @Richard_Slater,

Thanks for confirming that just the Node 2i is impacted here. Can you please let me know the exact local time + date + track you experience the next issue on? I would like to enable diagnostics mode to see if we can get further clues towards this issue from your logs, please let me know when possible, thanks!

I can actually provide that now
11 November
Track is “Following you” Shelby Lynne - I Can’t Imagine

1 Like

Hi @Richard_Slater,

Thanks for that timestamp!

I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis.

I see haven’t seen the report arrive yet, so please just let me know when you use the Core next and I can re-check for the report, thanks!

you should see that now hopefully - thanks!

Hi @Richard_Slater,

Thanks for letting me know, I can confirm that the log report has been received. Looking over your log, I do notice the dropout, but it is not clear as to the exact cause as to why:

11/11 14:06:42 Trace: [NODE 2i] [Lossless, 24/96 QOBUZ FLAC => 24/96] [100% buf] [PLAYING @ 0:06/3:43] Following You - Shelby Lynne
11/11 14:06:42 Trace: [Bluesound NODE 2i @] [raatclient] GOT [3700] {"status":"Dropout","samples":48158}
11/11 14:06:42 Trace: [Bluesound NODE 2i @] [raatclient] GOT [3700] {"status":"Dropout","samples":47916}
11/11 14:06:43 Trace: [Bluesound NODE 2i @] [raatclient] GOT [3700] {"status":"Dropout","samples":47916}
11/11 14:06:43 Trace: [Bluesound NODE 2i @] [raatclient] GOT [3700] {"status":"Dropout","samples":48158}
11/11 14:06:44 Trace: [Bluesound NODE 2i @] [raatclient] GOT [3700] {"status":"Dropout","samples":47916}
11/11 14:06:44 Trace: [Bluesound NODE 2i @] [raatclient] GOT [3700] {"status":"Dropout","samples":47916}

For next steps, I would do the following:

  1. Ensure you have the latest firmware installed (via the BluOS App)

  2. Try to factory-reset the Node

  3. I only saw one attempt at using System Output in your logs, when the issue occurs on the Bluesound, can you please check the System Output zone and see if the same issue is occurring there? It might be a network bottleneck but if you check System Output and Node at different times, the bottleneck may be absent.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.