DSD and Roon DSP Engine

Core Machine (Operating system/System info/Roon build number)
PC with Windows Server 2019, Roon 1.7 Build 511

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Twisted Pear DAC with 2x ES9018.

Description Of Issue
I have a few albums in DSD64 format and can play them in native format via my DAC without any problems.

Since a few weeks I have activated the Roon DSP Engine. I lower the level of the music tracks by -2dB to avoid inter sample peaks.

Now for the first time I also played an album with DSD64 and the DSP Engine. The signal is probably converted to a PCM signal, lowered in level and then converted back to a DSD signal.

Unfortunately, this signal is now only output in mono via my system. If I deactivate the Roon DSP Engine, the files are played back correctly.

Kind regards
Ralph

Hi @Ralph_Stens,

Can you share a screenshot of the Signal Path when this is happening, as well as a screenshot of the DSP settings?

Thanks!

Hello Dylan,
this is the DSP setting with -2dB Headroom


and here is the Signal Path

when I switch the Headroom off I have the following DSP setting


with this Signal Path
Screenshot_2020-02-17-14-18-10

With the second setting everything is correct, with the first setting I only hear a signal coming from the mid of my stereo speakers - it seems to be a mono signal.
Kind regards
Ralph

Hi @Ralph_Stens,

Thanks for those screenshots. It looks like you’re outputting to JPlay driver here, is the behavior the same if you enable the native DAC driver in Roon Settings -> Audio and play to the native driver with these DSP settings?

Hello Noris,

that is correct, I have a 2 PC setup with JPlay as transport software between both PC’s. The ethernet connection for it is a point to point wiring purely for these audio stream.

Therefore I can’t test the Roon setting as you ask for. There is no Roon bridge available on the Audio PC. The setup is quite complex and I’m glad that it works so perfectly. I don’t want to change something.

But without the Roon DSP Engine my system works perfectly with all material. I have also no problems with flac files up to 384kHz/32Bit and the Roon DPS Engine switched on. Only with DSD64 files.

Kind regards
Ralph

Hi @Ralph_Stens,

Instead of using headroom adjustment, do you experience the same behavior if you turn on Volume Leveling? You can do this by right-clicking the Zone name in bottom right (next to volume icon) -> Zone Settings -> Volume Leveling -> Auto.

Hello Noris,

I switched off the Roon DSP Engine and used the Volume Leveling -> Auto instead. I have the same result as with the Headroom Setting from the DSP Engine - the music is coming only from the mid of both speakers. When I set the Volume Leveling -> Off everything works fine.

Kind regards
Ralph

Where is the Sigma-Delta Modulator coming from? I was in the believe that DSP operations on DSD sources trigger a PCM conversion and with Sample Rate Conversion turned off it should stay PCM.

Hi @Ralph_Stens,

Thanks for confirming that Volume Leveling is exhibiting the same behavior.

Since this behavior seems to impact JPlay and testing the DAC without JPlay in the mix is not possible, I would suggest reaching out to JPlay regarding your report.

We don’t have JPlay in the QA lab so we cannot make guesses as to why this isn’t working. The QA team did confirm that this behavior is not seen when testing other output types.

Dear Noris,

ok, thanks for your help.

I havn’t so much DSD albums and it is very easy to switch the Roon Headroom DSP Function on and off. Due to this discussion I took a look at the Volume Leveling - which is a very nice feature - for the first time.

Kind regards

Ralph

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.