DSD native playback in RoPieee

Do you run Beta?

I think, it will not help you, that other users with other DACs (all my topping DACs can use DSD native with Ropieee) are able to use Native DSD.
Try the current beta and/or ask Harry, if he can add a kernel patch for your dac (he’ll need than the USB descriptor string from your device).

The DAC is already in there as it uses the same id as the M300.

Oooop’s. Beta behaves the same way :frowning:
So, the reason lies not in kernel itself, but in overall difference between RoPieee and Raspberry Bridge.
Now I consider pros and contras.

RoPieee. Display, artwork, controls and clock. Only DoP (lack of DSD512), can’t normally play higher than 352.8 kHz stream (“Loading slowly…” after 15 seconds and jump to the next track).

Roon Bridge. Native DSD up to DSD512. I don’t have “heavy” files but can use DSP software upscale up to 8x = 352.8 for CD and 4x = 384 kHz for Hi-res. But no display at all.

Nevertheless, my choise is RoPieee. And I’m open for “Test” channel update if Harry deside to correct different behaviour of RoPieee and Roon Bridge for my USB DAC.

Can you send me feedback?


This is for installed Beta

So @Neskoromnyi_Vladimir ,

Few things:

  • 'loading slowly … ’ messages are usually a server thingie: Roon has problems loading the track. So that’s not something you need to look for in RoPieee.

  • about native DSD: the patch for your DAC is present in the kernel (both stable and beta), so I’m wondering if you can share your device settings (in Roon) for this device with us.


Not at all. Not Roon has problem loading the track from Tidal or HDD (as a track is very “light”, 16/44) but RoPieee has time-problem in processing the track. As I wrote earlier, when I change system SD Card to Roon Bridge OS, this is no problem to 8x upsample of 16/44 and send 384kHz to Raspberry Bridge with the same hardware configuration.

Here they are:
Private zone = no
DSD playback = Native DSD - not working. DoP works fine.
MQA capabilities = Decoder and renderer
Volume control = Device volume
Volume limits = not set
Resync Delay = 0ms
Max sample rate (PCM) = Up to 384kHz
Max bits per sample (PCM) = 32
Max sample rate (DSD) = Up to DSD256
Zone grouping delay (ms) = 0.00
Clock master priority = Default
Enable MQA Core decoder = Yes
Buffer size = Default (also tested 500ms)
Multichannel mixing = Downmix as needed

Yes, and it works when I go to the Roon Bridge OS.

Again inserted Raspbian SD and made some manipulations.

  1. Installed Chromium browser.
  2. Open Roon Web Display by URL.
  3. Connect Raspberry controlled audio device to Raspberry display.
  4. Play Roon with maximal settings 384 kHz PCM and Native DSD256.
  5. See on Display what is playing

It works!
But nevertheless, RoPieee is better, despite the fact that artwork is limited by the disk cover only without photo and lyrics.
In RoPieee letters are bigger, control buttons, clock screensaver and autostarting display - all this is absent in Roon Web Display
So, I’ll use RoPieee though not with maximal settings

with this setting no native DSD is possible…

1 Like

With Fixed Volume is impossible too.

explain impossible.

Can you send me a logfile with volume control disabled?
Then I at least can see if RAAT sees the native DSD capability.

Here is it,


I think that “device volume” and “fixed volume” is the same configuration, since in Roon the volume is still locked, and my device change the volume not in digital way, but after decoding the sygnal.

@spockfish Thank you for your attention, so don’t mess if nothing can be done with my current setup. After all, my SMSL DP3 doesn’t have MQA capabilities, so I ordered new MQA DAC from Ali (Khadas Tone2 Pro). I hope that everything will be OK with both native DSD and FLAC upscale up to 512kHz playback for my new DAC.


I have the same issue, I am running with Amanero combo384 USB interface and there’s no “native DSD” option available in Roon when I connect it to Pi4 running Ropieeee.

Software Version: RoPieee 2022.02.2 (0070)
Kernel Version: 5.10.95-SPCKFSH-v7l
Board Type: Raspberry Pi 4 Model B Rev 1.1

Find out the Amanero firmware version. If it’s something earlier than 2006be10 it won’t work well on Linux.

1 Like

Have updated to the latest version oem tool 117, still no luck

I tried again and found that I just didn’t select the right firmware when flashing. Now it works with native DSD.

Unless you’re been told by respective hardware manufacturers to use this very old firmware, I don’t think it’s good - it probably does not work well for DSD256 or above.

However, if everything works for you now, then it’s great.

Check whether you experience left / right channel swap with DSD music.

Thanks for your kind reminder!