DSD not playing on Allo DigiOne / Ropieee

Hi folks

So I’ve tried Roon set to: Convert to PCM, DoP over PCM but I can’t get DSD tracks to play on my Allo DigiOne/Ropieee set up.

Connected via coax into an Arcam AVR850.

There aren’t many options in Ropieee to play with.

Any idea what I need to do? I would have thought that as long as Roon Core is converting to PCM then it should play fine but it doesn’t.

You need to set the DigiOne to DSD over PCM. However, this is immaterial since the Arcam doesn’t support DSD. Therefore, convert DSD to PCM.

Yes, that’s what I think too but there are very few settings in Ropieee and I can’t see any related to changing DigiOne to DSD over PCM. Do I need to use Volumio instead?

No! Your DAC doesn’t support DSD so there’s nothing you can do. The DigiOne is passing DSD to the DAC but it can’t do anything with it.

Your only option is to cover DSD to PCM.

Forgive my ignorance here but can’t Roon convert DSD to PCM before sending it onto the DigiOne? In which case, the DigiOne just see’s a PCM stream at 24/192??

And hence all that gets passed to the Arcam DAC is a 24/192 PCM track? (as in, all codecs stripped out)

I think you may be confusing DoP with DSD to PCM conversion. DoP is sending DSD to the DAC but it is encapsulated in a PCM stream (that’s a max. DSD64 as S/PDIF max. PCM is 192kHz.)

You need to set your DSD playback strategy to Convert to PCM. Go into Device Settings to make the change.

Well I’d already done that and it still wasn’t working.

BUT, I have now figured it out. I use Roon’s DSP to do sample rate conversion to 24/192. And it now works as expected. I dunno why but I was assuming that by setting ‘Convert to PCM’ in audio setup on the Allo device that it would do this automatically. Alas, it seems I have to do the sample rate conversion instead. I don’t mind converting everything to 24/192 so I’ll just leave the DSP enabled when I’m using the Allo.

Thanks for your help Martin.

1 Like

In case you didn’t realise, you can set this up for DSD only under Custom on. the Sample Rate Conversion screen.

However, the Device Setting option should work for you. See my signal path below. Can you share this where DSP sample rate conversion is off and convert to PCM is enabled under settings?

OK cool. Here’s the signal path with DSP disabled but ‘Convert to PCM’ enabled in the audio device setup:

And this is the signal path with sample rate conversion enabled:

So what is interesting is that they look identical except that I’ve added a -3dB headroom to the SRC that the DSP is doing.

So I tried using the Custom setting so that only DSD64 … DSD512 were converted to 24/192. No sound.

At the moment, I can only get DSD files to play by using the ‘Max PCM rate’ setting under the sample rate conversion.

Yes, it is strange and I suspect something to do with the DAC.

Others may pitch in but the thread needs to move to the correct category #support as it’s not a Ropieee issue.


Sorry yes, you’re right Martin. Thanks for your help.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.