DSD playback ability lost on the Auralic Aries after upgrading to 1.2

I am using Roon on a HP Envy Laptop running Windows 10 as my core. I upgraded to version 1.2 today and lost my ability to play DSD through my Auralic Aries. This had been working in version 1.1. My Aries is connected to a Marantz AV8802 processor via a digital coaxial cable. In version 1.1 when I went into the Aries setting in Roon I was able to select the DSD playback strategy as well as the maximum sampling rates. That option is no longer available in 1.2 and I can only set max sampling rates in PCM. When I attempt to play DSD files there is no sound.

I do still have the DSD playback strategy options on my Oppo HA-2 DAC in 1.2. The DSD options only seem to have disappeared on the Aries. I did doublecheck my DSD settings on my Auralic and they remain set up correctly for DSD playback. I also restarted both my laptop and the Aries but that did not seem to have any effect.

That option is no longer available in 1.2 and I can only set max sampling rates in PCM. When I attempt to play DSD files there is no sound.

Just to clear something up: Roon has never had a “DSD Playback Strategy” setting for RoonReady devices like the Aries. That setting is for direct-connected outputs only–RoonReady devices manage their own DSD playback details (this is done in Lightning DS for the Aries).

One detail I’m not 100% clear on is whether or not your AV8802 supports DoP-encoded DSD on its coaxial input or not. I’m also not clear on what exact settings you’ve chosen in Lighning DS or Roon, so I’m guessing a bit here. If I’m off the mark, help me understand some of those aspects and we’ll dig deeper.

Anyways, I just pulled an Aries down off the shelf, set it up to use the Coax, and ran through some test cases.

I plugged it into a DAC that I know can do DSD64 in DoP mode over Coax.

First I enabled “DSD over PCM (DoP V1.1)” in Lightning DS. In that configuration, DSD playback works fine, and the DAC recognizes the stream as DoP and plays it properly with this signal path:

Then I disabled the DSD Over PCM setting in lightning DS and played the same file. Now, Roon converts the DSD to PCM on the server, as I would expect:

Unfortunately, I hear silence…Maybe this is the thing you’re running into, not 100% sure.

Anyways, there’s a good answer to why I’m hearing silence: The Aries is trying to play 352.8k audio out its Coaxial S/PDIF port, and that’s too high of a rate for S/PDIF.

This is happening because the Aries tells Roon that it can support that format. I’m not sure if this is because Auralic knows of situations where that rate is useful, or if it’s just a minor oversight in their RoonReady implementation.

I got things working again by switching the “Max Sample Rate (PCM)” setting to 192k. That made Roon do this instead:

And that makes DSD64 playback work for me again, since 176.4k over S/PDIF is ok.

Thanks Brian for the quick and detailed response. It has helped me narrow down the issue. In the first scenario with the “DSD over PCM (DoP V1.1)” enabled on the Lightning DS I do get the signal path you posted, however, I get no sound,. Prior to upgrading to 1.2 this signal path worked fine.

If I change the settings as you described to have Roon convert DSD to PCM everything does work, however, I would prefer to regain the DSD playback.

Maybe we have different Aries firmware versions? I am on 3.2. What are you running?

I am also running 3.2 - thanks

Ok…thinking further.

DoP streaming is fairly sensitive to anything that messes with the bitstream at all. The code that passes DSD to RoonReady devices is the same for all of them, and others (including my Aries) are working, and we really didn’t change much in 1.2 for RoonReady devices, other than a few bug fixes that aren’t in this area.

You said you restarted the laptop and the Aries. What about the Marantz? It’s worth a shot…

In case that doesn’t work, @mike lets grab logs from @Ian_Ide’s Roon install. Maybe something will pop out at me.

I performed a soft reset on the Marantz and, unfortunately, it did not resolve the problem.

As a next step will @mike be reaching out to me for the logs?

Hi Mike - I received your PM but was unable to reply to it. I just sent the logs. Below is the additional information you requested:

  • I am running Roon version 1.2 Build 123 64 bit

  • My OS is Windows 10 Home

  • My core install is running on a HP Envy laptop with an Intel Core i7 2.4 Ghz CPU and 12 GB of RAM

Please let me know if you have any additional questions. Thanks for your help.

  • Ian

Hey @Ian_Ide – we looked at the logs you sent and did a little more research. We weren’t able to find confirmation that this device is able to handle DoP over SPDIF, and others seem to be saying it does not.

Are you sure you weren’t converting to PCM in 1.1? That seems like the most likely scenario here, but maybe we’re missing something. Let me know and we’ll take another look if you know something we don’t.


Thanks Mike. There certainly is the possibility that I could be confused. Here are some additional points that may or may not be helpful:

  • A couple months ago, attempting to listen to DSD on my Marantz with this set up produced white noise until Auralic rolled out firmware version 3.2. After that it worked fine. My experience was the same as what others were experiencing in this thread:
  • After upgrading to Roon 1.2 I had to change the DSD over PCM (DoP V1.1) setting on my Aries in order to get sound from Roon. My previous settings were no longer working.

That said, I decided to test the issue by attempting to play DSD files through this setup using Auralic’s Lightning DS app. I accessed the DSF file from a USB stick that I placed in the Aries. I was able to play FLAC files but I could not get sound from the DSF file with DSD over PCM (DoP V1.1) switched on or off. With it on I got some sort of light static and with it off I got no sound at all.

One complicating factor is that the day before my test Auralic upgraded their firmware and made the following change – “Disable “DSD over PCM” only works on USB DACs that support sampling rate to 352.8K.” so it may be that my the test was not entirely “apples to apples” to my experience prior to upgrading 1.2. Either way, it’s looking like direct DSD over the coax is not currently possible. Unfortunately the Marantz will not recognize the Aries via USB so coax is the only option.

Thanks again for your help here. You guys have come up with a revolutionary product!

Please let me know if you have any additional questions.