DSD Playback Issues on NAS

Hi Noris,

I have the same issue.


  • Synology 1517+, 16GB RAM, 256MB M.2 SSDx2
  • Roon Core ver. 2018-03-07 installed
  • Roon database stored on external SanDisk 2TB SSD via USB 3.0
  • Music files stored on NAS HD configured as RAID5
  • KEF LS50 wireless speaker
  • Wired network between NAS and speaker, via Netgear router


  • Intermittent break while playing DSD, both 64 and 128
  • All DSP filters are turned off
  • Same when Roon is the only active task
  • MP3, 44k/16b AIFF, 96k/24b FLAC, 96k/24b MQA all worked fine

Attached are screenshots of signal paths playing DSD64/128 and typical NAS performance when playing DSD.


Hello @Ronald_Lai,

You should be aware that this NAS does not meet our Roon Minimum Requirements, it looks like it uses an Atom CPU according to the spec sheet, which might be impacting this behavior.

Does this behavior only occur on your KEFs? If you try playing to a different zone, does that work as expected? If you temporarily try connecting your KEFs via USB, is the behavior the same?

Thanks and a good catch, Noris.

The same DSD files played smoothly on my ifi Pro iDSD. However, this connection may not be a fair comparison because the data path just involves transporting but not downsampling. So I tried to simulate the KEFs case by playing on my Mac which will need downsampling (similar NAS loading). Playing was smooth and no intermittent breaks at all. Both single paths attached.

KEF LS50 wireless firmware version:
Wi-Fi: v3.0.0
MCU: v4.1.0
DSP: v0.54

Appreciated further suggestions.

Add images

In addition, playing same DSD files via USB to KEF LS50w is fine i.e. no intermittent break issue.

Hi @Ronald_Lai,

Is the behavior the same if you temporarily use your Macbook to host the Roon Core and play to the LS50s via the network?

Yes, the issue is the same when I use my MacBook to host the Core. However, the problem solved if the LS50w is configured with Max Sampling Rate to 96kHz. Device setup screen attached.

Further testing shows the problem occurs not only in DSD64/128 but also PCM 24/192 file. The signal path is attached.

To understand if the LS50w simply can’t play 24/192 smoothly via network, I tried to play the same 24/192 files via DLNA from the same NAS both wired and wirelessly, and it played fine. The problem comes back when changed back to Roon + Max Sampling Rate set 192kHz.

Hi @Ronald_Lai,

Thank you trying the MacBook Core and for confirming that this behavior also occurs when streaming 192 content via the network but not via USB.

We are aware of some reports from users of issues regarding playing higher sample rates on KEF gear and we’re working with KEF to troubleshoot this further.

We have anecdotally heard that in some cases, a factory-reset of KEF speakers help with this issue. You may want to give this a try to see if it helps, it’s listed under section A5 of the KEF LS50 Manual.

Tried to reset my LS50w, setup the speaker from the beginning. Situation is the same. Will leave device setup to 96kHz for the moment in order to enjoy some music.

Will setup a Raspberry Pi with HiFiberry hat and run the tests again. Hope the KEF doesn’t inferior to a RBPi in terms of ROON connection :wink:

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.