DSD Stuttering on Seek/Track Change


Received an LHLabs Pulse DAC (standard, if that matters) yesterday and set it up to play DSD via DoP to WASAPI (couldn’t get it to work with native DSD, but that’s for another thread).

When playing a DSD track, if I try to seek into another location in the track, stuttering starts. If I stop and start playback again, it plays smoothly.
Also, if DSD is playing and I click next and the next track is in DSD, stuttering starts. If the next track is not DSD it doesn’t happen.
When I put a bunch of DSD albums in shuffle and let the tracks change without clicking next, sometimes there is stuttering when a new track starts. However, if I’m playing a full DSD album it doesn’t seem to happen.

I tried playing around with resync delay but it didn’t work, which makes sense because that is only for switching between different sample rates.

Would appreciate any help!

Hi Chikolad,

I’ll set a notification for @vova and he’ll pop in to investigate further.

Thanks @andybob!

Hey @Chikolad, thanks for the report. To us it sounds like a driver/device bug issue. So, let’s start our troubleshooting from basic questions.

  • Can post the screenshot of the LHLabs Pulse DAC zone ‘Output Settings’ in Roon?
  • What operating system you are running ?
  • Which version of the drivers you are using ? Have tried the newer/older ver# of this driver?
  • Have you tried to use this DAC with ‘Event Driven Mode’?
  • Have you tried to reboot/restart OS and Roon ? :wink:

Hi @vova!


  1. Windows 10

  2. If you mean the LH driver, it’s version 2.23 which from what I understand is the latest that fits my hardware. Here is a screenshot of the info:

I’m also using WASAPI and not the ASIO driver.

  1. Already using ‘Event Driven Mode’.

  2. I have not rebooted my OS :slight_smile: I did restart Roon just now and was able to reproduce the stutter upon seeking. If you think it’s worth a shot I can also reboot.

Also, here are the buffer settings of the driver. I tried changing the ‘USB Streaming Mode’ but it doesn’t solve the problem.