DSD to PCM conversion no longer working on new system [Resolved - 1.3]


DSD to PCM conversion was previously working when I had this layout (all connections by ethernet) :

Roon Core PC to Onkyo receiver via optical cable, output limited to 24-96

I got a new TV so decided to also get a NUC with the impending release of 1.3 and Multichannel support so now the layout is :

Roon Core PC sending to Roon Bridge on NUC then HDMI to Oppo BDP-103 then HDMI to Onkyo TX-SR805 receiver (no DSD capability).

Depending on what settings I use I either get silence or clicking, not sure why this is not working as it did before :

The NUC passes through 24-192 PCM without a problem.

Any ideas please ?


Hi, looks like you are passing audio via HDMI? Try the Oppo on its own as you may be limited to the lowest rates enabled on the connected machines.

Yes I am using HDMI, not sure what that has to do with the inability to convert DSD to PCM ?

What do you mean when you suggest using the Oppo on its own ?


Daisy chaining HDMI through the Oppo player likely but not definitely is the cause of the problem. Why are you following such a convoluted signal path? Just send HDMI directly from the endpoint to the Onkyo AVR.


Yes I agree it does sound excessively complex. I guess I can plug the NUC straight into the Onkyo and plug my cable TV box into the Oppo and pass that through instead.

Will try tomorrow


Are you running short on HDMI inputs? Is that the issue? If so, you ought to add an HDMI switch. Or, honestly, replace the AVR. As I recall, that Onkyo is pushing a decade old, thus growing increasingly outdated. Alternatively, connect the cable box directly to the TV, as little is gained by passing HDMI from the cable box through the AVR to the TV.


BYes I am short of HDMI inputs.

I plugged the NUC direct into the AVR and still it cannot convert DSD to PCM, this is what output is showing :

So there problem must be in Roon, how can I fix this ?

How do I flag to Roon Support ?


Go into the settings and re check the convert to PCM tab.

Yes convert to PCM is definitely selected

How can I flag to Roon Support please ?


You write: limited to 24-96.
I see 192, so try the 44 and 96 option.
I think the Onkyo can not play 192.

You flag support by typing @support.

@support please help


Yes my Onkyo can play 192

Yes, but not with all inputs (manual).
Just try it.

I can play FLAC at 24-192 via HDMI, that’s not my problem. Roon is not converting DSD to PCM as it should


Hi @Jaap74 ---- Thank you for the report and my apologies for the troubles. I see from your post from a day ago you mentioned the following:

" I guess I can plug the NUC straight into the Onkyo and plug my cable TV box into the Oppo and pass that through instead."

With this new configuration in place can you please provide me with updated screenshots of your playback settings in Roon?


Hi Eric,

Playing PCM 24-192 at present no problem :

AVR shows :

Trying to play DSD with these settings :

All I get is a clicking noise which makes sense as according to the Signal Path screenshot above the conversion to PCM is not taking place despite my settings.

Thanks for your help !

Hi @Jaap74 ----- Thank you for the follow up, your feedback is greatly appreciated!

I would like to grab some logs from you so our developers can have a closer look into what may be causing this behavior to occur. I will be contacting you momentarily via PM with instructions.