DSD with Roon, DSP convolution and exasound s88

Your 0.9 processing speed is far too low (needs to be over 1.3), meaning you configured the DSP to do far too much than your CPU is capable of.

What is the processing speed in the signal path after you Disable Native DSD Processing?

Were you saying it did not work smoothly even with it disabled?

Yes Ka. This is one option.

When switching off the native DSD processing the speed falls to 0.3-0.4, even worse!

That shouldn’t be.
Can’t you show your used signal path in a screenshot?

2 Likes

Here’s a screenshot. I habe actived DSD to PCM conversion. The signal path looks as follows:

What surprises me: Why even in PCM mode the number of taps of the convolution filters is boosted from the 524k to almost 2.000?

Aah, your problem isn’t DSD, but your filters.
What you can do (if you must use the filters) is to convert DSD to PCM 88.2 or 176.4.

Well. Yes and no. All filters for all sampling frequencies are 524k taps. And all work well for PCM input, regardless fs and with processing speed usually around 10-15x.

The converted DSD to PCM uses almost 4x the number of taps. Roon must generate them from the original ones. Clearly for DSD native input this makes sense. Is there a setting in Roon allowing to use the original filters with a DSD to PCM converted signal?

Anybody from the Roon team to comment?

Hey Support Team: Any technical feedback on this issue?

Have had some time to play around with Roon.

Experiment 1: Switching SRC in DSP on and define custom target for all DSD of 192kHz: No effect. Roon does still create weired convolution filters. Switching SRC on/ off and/ or varying the custom target Fs doesn’t solve the problem.

Experiment 2: Limit the max PCM frequency in the device settings to 192kHz: That does solve the problem (see screenshot). And this does not need SRC to be enabled. It seems to trigger an automated conversion.
[image]
What this doesn’t solve: The weird filter tab length. This only becomes the correct 524k taps, when the maximum Fs is 96kHz or lower.

Any ideas on the root cause of this behaviour?

Cheers, Ralf

Hi @Ralf_Hoellmann,

We apologize for the lack of a timely response and thank you for the additional information.

If Roon detects that you have not included in your convolution filter zip file a filter that matches the sample rate of the content it will automatically resample the filter to match the content.

For example:
Media: 96 kHz
Filters: 44.1kHz @ 5000 taps, 48kHz @ 5000 taps
Result: Roon will resample the 48kHz filter to 96kHz, doubling the number of taps to 10000.

What sample rates have you generated filters for and included in your zip file?

-John

2 Likes

Hi John,

thanks for your reply. I have already read in the documentation that Roon does extrapolate. I have got all CFGs and WAVs for 44/88/96/176/192/352/384k.

The WAV files have got the correct Fs. However, re-evaluating the the CFG files, I have had an error: It should have read 352800 (not 352000). When reading the ZIP, Roon does seem to ignore the real Fs of the WAV when the Fs specified in the header of the CFG isn’t correct.

So, this is clear now.

Regards, Ralf