DSD works but no sound

Core Machine (Operating system/System info/Roon build number)

Mac Mini MacOS Mojave(10.14.6) Roon 1.6

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Benchmark DAC2 (USB2)

Description Of Issue

Roon is reading the DSD-file and everything is working as it should. But there is no sound. It was working as it should one day and the next day it didn’t. No settings were changed. I’ve checked all the settings, and they are as they should.

Hi @Marino_Marinkovic,

Can you share a screenshot of Device Setup for this zone, as well as a screenshot of the Signal Path when playing DSD content to it?

Is this occurring with all DSD content?

If you play DSD content to other zones does it work as expected?

This is occurring with all DSD content!

Funny thing is, that everything “looks” okay. Roon is playing the the music and it is carried to the DAC-but there is no audible output. There should be, but there isn’t, and there is no visual que to what could be wrong.

Hi @Marino_Marinkovic,

Have you tried a different USB cable yet? I would give this a try. Also, can you please share a screenshot of your Device Setup tab for that zone and a screenshot of the Signal Path you see when audio is playing? Device setup should look something like this and Signal Path examples can be found in the linked documentation:

At the moment I can’t take a screenshot, because nothing works until Roon has fixed compatibility issues with latest MacOS Catalina.

Regarding the USB cable; it works for everything else, and it worked fine with Roon as well, until “one-fine-day” it didn’t. Whatever is wrong has something to do with software.

I did have two screenshots that I took, but I can’t find them now. Probably deleted them. One shot of the setup which looked like this. My audio device is a Benchmark DAC2.

My signal path is not showing any anomaly. Only problem is that there is no sound, though it should be. And it changed from one day to the other … prior MacOS Catalina update.

Hi @Marino_Marinkovic,

Can I ask you to reproduce this issue and let me know the exact local time + date it occurs in your country and the track that’s playing? I would like to take a look at diagnostics to see if it reveals any further clues.

You should be able to drop a DSD file in your Mac’s music folder as a test while we investigate the issue with Catalina which affects external drives.

Also, just to confirm, you were experiencing this issue before upgrading to Catalina, correct? It does seem to be the case but I just want to verify. Thanks!

Yes! I was experiencing this issue before upgrading to Catalina, that is correct!

Roon doesn’t find any files … for now I have to use Apples Music to listen to my files.

I’ve dropped a DSD-file in the Mac’s Music folder. The local time is. 00:00 Friday, 18 October.

Hi @Marino_Marinkovic,

Can you please share a screenshot of your Roon Settings -> Storage tab? If the files are stored in your Music folder, they should show up as long as Roon is watching this folder.

Also, can you confirm regular PCM content plays as expected on your benchmark zone? Are you able to output the DSD file to another zone, such as “System Output” for example?

There is actually not much to do at the moment; just wait for a resolution on the problems with MacOS Catalina.

Hi @Marino_Marinkovic,

That screenshot is certainly strange, do you have any regular FLAC files saved in your Music Folder?

If not, I would drop a few in the music folder just to confirm that those show up as expected, if you don’t have any you can grab a few from the 2L Test Bench.

Are the DSD files showing up in the Skipped Files Section of Roon by any chance?

There are over 700 non-DSD albums, which I can listen to in Music. Obviously there is a problem with compatibilty beween Roon and MacOS Catalina. We’ll see when Roonlabs has a fix what happens. Annoying to say the least.

Now that Roonlabs has updated the software to work with MacOS Catalina, everything works as it should; including all of my DSD-content!

Thank you everyone for trying to help me.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.