DSD128 playback through Vivaldi DAC [Solved]

I have installed version 2.0 of the Vivaldi firmware which should enable the DAC to play DSD128. When I play a DSD128 file Roon appears to convert it to PCM at 176.4kHz. DSD64 files play as DSD, so does anybody have any suggestions. BTW, my endpoint is a microRendu with USB into the DAC.

Hi Robert,

First thing I’d check is Settings/Audio/gear icon next to the Vivaldi zone/Playback - is Max Sample Rate (DSD) disabled ? If not, try disabling it.

If that doesn’t solve it, can you upload screenshots of both the General and Playback tabs for the Vivaldi zone ? Use the upload tool (bar and up arrow) in the menu of the edit window when replying.

Hi Andrew,
Yes, Max Sample Rate is disabled.
Attached are screen shots, I hope they’re the ones you require.

Thanks Robert,

Does the microRendu RoonReady settings page look like this:

Yes, that’s it exactly.

Ok, that’s the easy stuff. Let’s drop flags for @mike and @vova to investigate further.

Just to confirm – the DSD-over-PCM option is checked, right?

I do not see a DSD-over-PCM option in the microRendu settings. However, it does play DSD64 and the DAC shows as DSD on its screen.

Mike is asking about the check box in the microRendu webpage I screenshotted above.

It reads:

Enable DSD-over-PCM [ ] If your DAC supports DSD-over-PCM (DoP) enable this to send PCM encoded DSD to your DAC"

Can you confirm that the check box on that screen is checked ?

OK, yes it’s checked.

Hello. I’ve just updated my Vivaldi DAC as well. You should click on a drop down menu: Max DSD Sample rate; then just choose DSD128. Mine was converting to PCM just as you described because my Max DSD Sample rate was set to DSD64.

Best regards,

Thank you for your suggestion. I checked the settings and my Max Sample Rate is set at DSD128 for the Vivaldi.


What’s the Core running on here?

Also, is it possible to temporarily remove the MicroRendu and confirm whether this issue happens when the Vivaldi is connected directly to Roon or RoonBridge?

Hello Mike,

The core is running on a CA Zuma with 32GB RAM Windows 10, all equipment is connected through ethernet off a single cisco switch.

I removed the microRendu from the DAC and ran from my MacPro, same results, DSD128 converted to PCM, see screen shots.

Since Rodrigo’s system is working with DSD128, I obviously have something set incorrectly.


Problem Solved. I reselected the USB Class 2 mode in the DAC. Now it is playing DSDx2.

Yes, it should appear DSDx2 in your Vivaldi display.

Taking the opportunity, here is the new add ons provided by the new firmware 2.0 (i got this info directly from one of their directors):

Once the Vivaldi DAC software is installed, you will find a new option within the settings called Mapper. The Mappers are the various algorithms for the Ring DAC i.e. the sequence in which the data is fed to the latches in the DAC. The Mappers are as follows:

Mapper 1 – this is the new enhanced, double speed mapper and offers a huge leap in performance compared to the original mapper. This is the recommended mapper.
Mapper 2 – Original mapper, which has been improved.
Mapper 3 – Same as 1, but this has a different way of supplying data to the latches on the Ring DAC board.

You will also note that there are now 5 filters when upsampling to DSD. Filter 1 to 4 are the standard DSD filters and Filter 5 is the new Filter. The combination of Mapper 1 and Filter 5 for DSD will offer a substantial leap in performance.

Hi Rodrigo,

I found similar info in the updated user manual, which is where I found the note to reload the USB2 mode.

I agree with you, the Mapper 1 with Filter 5 on DSD is very good.

I would like to explore if it’s possible to support native DSD on this device. Can you post the information found in Apps/DAC Diagnostics from the GUI?

Here it is…