DSD128 with DietPi, Allo USBridge and Directstream DAC

(Christoph Seemann) #1

Hi everybody!

I have a little problem with my setup which looks as follows:

QNAP NAS with files -> Win 7 Server with Roon Core -> Allo USBridge -> PS Audio Directstream DAC USB Input

All connected via Ethernet

All components are running the current firmwares :wink:

When I configure the Device Settings to DoP and DSD64, DSD64 files are played as DSD64. DSD128 and DSD256 are downsampled to DSD64. So far so good and everything works and sounds great :wink:

But when I set the Device Settings to DoP and DSD128, I only get some high beeping noise, regardless what DSD files I play.

As far as I know the USBridge with DietPi should handle DSD128 and the USB-Port of the Directstream should also handle DSD128. Any idea why this is not working?

Thanks

Chris

#2

Chris,
Have you contacted Allo about this as well to get their input?

(Christoph Seemann) #3

Hi!

Yes I have, no answer yet.

Chris

1 Like
(Sean) #4

Can you share a screenshot of your Roon signal path playing DSD128?

Also, all your Roon settings for your USBridge zone?

(Christoph Seemann) #5

Yes sure, here they are.
First with settings for DSD64:

!

And here with DSD128:

(Sean) #6

Thanks, but that’s playing DSD256. I can see your processing rate is low… not saying that’s the issue but it might be related…

I asked for the settings and signal path playing DSD128, if you can.

So setting up Roon to play DoP128 and playing a DSD128 track, any issues with the sound quality?

(Christoph Seemann) #7

Hi!
Yes, playing a DSD128 file when setting is at DSD128 results in exact same noise, as when playing the DSD256 file at the DSD128 setting.
Here is the screenshot from the signal path when playing the DSD128 file. Looks ok.

1 Like
(Sean) #8

Hmmm yes I agree, that looks good.

I’m out of ideas of things to try unfortunately.

Did Allo get back to you?

Maybe @rahulkc_s @allo.com can help here.

(Christoph Seemann) #9

Yes, Sudeep from Allo came back to me. His first attempt was to check, if the USBridge is set to ‚USB-DAC‘ as soundcard and not ‚USB-DAC 1.1‘, to make sure there is enough bandwidth using USB 2.0. That settings was correct (I also changed it and then changed it back again to be sure) so that was not the case.
He then asked me to ssh into the USBridge to make some commands (see screenshots below). There he could see that the Directstream connected via USB supports PCM to 352 khz and no DSD. That seems to be right, as I have to configure Roon using DoP.

But then I noticed something. In Roon my Directstream has set 384 kHz as maximum sample rate (see screenshot above). That’s the standard setting when I click on ‚Identify your device‘ and search for the Directstream DAC. But the maximum for the Directstream DAC via USB is 352 kHz. Maybe this is the problem? What I have read is that DSD64 via DoP requires 174 kHz PCM and DSD128 via DoP requires 352 kHz PCM. But what is Roon sending to the DAC when DSD128 DoP is set? As Roon believes the DAC can do 384 kHz, is it maybe sending a 384 kHz DoP Signal to it, which the DAC cannot understand? Does anyone know? How can I set the maximum sample rate to the correct 352 kHz and not 384?

Here are the DietPi Screenshots mentions earlier:

(Christoph Seemann) #10

@support any idea how I could set the maximum bitrate for the Directstream DAC correctly? its 352khz and not 384. I only can choose between 192 (or lower) and 384. maybe that would also solve the DSD128 problem.

(John) #11

Hello @Christoph_Seemann,

The maximum input sample rate of the PS Audio DirectStream DAC USB input is 352.8kHz. This should allow for playback of DSD128 content via DoP.

The maximum sample rate being shown as 384kHz in Device Setup screen is a bug, and I have reported it to the QA team.

Make sure that you have updated your DAC to the latest firmware from PS Audio, version 3.0.6 at the time of writing.

With firmware 3.0.6, I have been able to play DSD128 content to the DAC via ROCK without issue.

-John

(Christoph Seemann) #13

Hi John!

Thank you for the tip! I had the Snowmass Firmware on the DAC but not the 3.0.6 version. I just updated to 3.0.6 but there is still the same problem.
Did you have the same problem with firmwares lower than 3.0.6?
When it is working with ROCK and not with Allo USBridge, maybe the problem is there. @rahulkc_s @allo.com any ideas?

(Allo.com) #14

as per latest shared results (PM) , updated firmware supports DSD native.

share the lsusb results again.
through PM test driver link shared.

(Christoph Seemann) #15

Hi!

First of all: the Directstream DAC cant do native DSD, it can only accept DoP.

I did the update according to your procedure, but the effect is the same. It is true that I can see in roon now that I could choose “Native” in the Device Settings and also up to “DSD 256”. So the update seemed to be successful. I tried “Native” but I only got continous static noise. With DoP and DSD128 it is the same effect as before: a repeating beeping noise.
Here is the lsusb BEFORE the update:
lsusb
Here is the lsusb AFTER the update:
lsusb-new

(Christoph Seemann) #16

Hi everybody!
Sudeep Kumar from Allo wrote me an E-Mail and said that the Problem seems to be at PS Audio, as he could not find any error within the USBridge.
Today I took my Windows 7 Notebook, installed Roon on it and the PS Audio USB-Driver. I connected the Directstream DAC directly to my Notebook (which I used as a Remote for my existing Roon-Setup) and configured it as Audio Output. And voila: DSD128 is working without a problem.
So:
Directstream DAC connected to Win 7 Notebook via USB: DSD128 is working
Directstream DAC connected to Allo USBridge via USB: DSD128 is not working.
Any more ideas?