DSD512 Support with my iFi Retro Stereo 50

I have an iFi Retro Stereo 50 which supports DSD512. However, when I go into Device Setup in Roon, it will only allow me to select up to DSD256 as the max sample rate. Then when I go to play any of my DSD512 files, it down-samples to DSD256, and there are hesitation problems. The only way I can play my DSD512 files is by changing the DSD Playback Strategy to Convert to PCM. What can I do so that the Roon software will recognize that my DAC supports DSD512? Thanks.

Is the DAC connected directly to the core or another playback device? Please list what you music chain is so support and others can help you better.

Yes, it is. I am using a Microsoft Surface Pro (Windows 10) as my core and I am connecting my iFi Retro via the USB cable, which should allow me to play DSD512.

Make sure you are using the asio driver to get native dsd. And that playback is set to native not DoP.

It seems to have defaulted to WASAPI. How do I change to ASIO?

If you go to settings audio, there should be an asio driver. Enable it and give it a name. Then under the asio device settings, make sure DSD strategy is set to native. Then select it as your output device.

If the indicated processing speed in the signal path is under 1.4x then you should try parallelize sigma data setting. If that still doesn’t work it’s your core cpu not fast enough. See


Interested to know where you are getting dsd512 native content from though.

When I go into Settings, Audio, this is what I see:

. I don’t see any other drivers or anything. No option for ASIO.

Looks like I’m okay on the processing speed (3.2x):

I’ve been purchasing most of my DSD music from nativeDSD.com. They only recently began carrying some DSD512; only a few albums so far.

The drivers are located here: https://ifi-audio.com/downloads/
And file is : iFi (by AMR) HD USB Audio Driver 3.2.exe

This should install both ASIO and the Wasapi drivers according to their page. If both are not installing then you might need to contact iFi. One thing I noticed is this:


When a Core is playing to an output attached to itself usually label it “My PC” not the computer name. Is your Surface actually called ‘Desktop-OIPDL2F’? If not, the device where the iFi is attached to is the where the drivers have to be loaded.

Thanks Rugby. As you were posting this, I had just stumbled upon the drivers on the iFi website. I’m not sure why it didn’t occur to me sooner that perhaps my core PC didn’t have all the required drivers. I closed Roon, disconnected my hardware, installed the drivers, reconnected everything, back into Roon and, sure enough, the ASIO option was there. I enabled it, selected Native as the DSD Playback Strategy, and now all is good!! Re: your last question, the screenshot was indeed from my desktop (Roon Remote) and not from my Surface (Roon Core). But, yes, naturally I installed the drivers on my Core.

Thank you very much to you (and to Mr. Fix it and CyrstalGipsy for the quick and informative responses. Much appreciated.

1 Like