DSD64 skipping while streaming Tidal on Mytek Manhattan II

I am using Tidal/Roon on my iMac with macOS High Sierra with 2.9GHz Intel Core i5 for streaming only to Mytek Manhattan II with the optional network card. Mytek allows PCM 24/192k or DSD64 for streaming. While PCM sounds great I think I still prefer DSD sound. Unfortunately DSD hiccups or “skips” once in a while. Is there a simple solution to that?

What’s your processing speed during DSD playback? And did you select Parallelize SDM in the Roon’s device settings for the Mytek?

Parallelize SDM has always been selected. Where do I find processing speed?

In the signal path. If it’s over 1.3, then that’s not the problem.

Processing speed is 16x

1 Like

Hello @John_Jonczyk,

Does Roon or the Mytek present an error when this behavior occurs? Or does playback just momentarily pause and resume without any feedback that something wrong has occurred? Are the symptoms the same every time?


I didn’t notice anything in Roon or Mytek. Just a very audible pause that lasts maybe half a second to a second.

Hello @John_Jonczyk,

Let’s try and get a sense of what’s going on here. What I’m going to do is enable diagnostic logging on your account. The next time you see this behavior occur, please reply to this thread with what the time (local time) that it occurred. Once I have that information, I’ll be able to request logs from your Roon Core during that time period for further analyzing.

I should also note that the Mytek Manhattan II has not yet completed the Roon Ready certification process. We have been working with Mytek to get this done as quickly as possible, but there may be edge cases where functionality or stability is subpar until we complete certification.


Thank you for your reply. I will let you know sometime tonight at what time I noticed the hiccups in DSD64. This should not be a problem as it sometimes occurs couple of times a minute, sometimes however once every few minutes. I briefly spoke with Michal at Mytek the other day and he thought it might be my Mac’s processor that has a problem handling DSD64. I am not sure about that as my Mac has Intel Core i5 which should be quite capable of handling it. Hope you can shed some lite on this annoying problem. BTW, the Manhattan II is brand new and I’ve had it for only couple of weeks.
Thank you, John

It happened at 7:59PM, 8:00, 8:03 and so on…

I have this issue too. My best guess would be that it is a network problem; just too many data going through the wire.
I got a core i7 (macbook).
And yes Mytek need to finish the certification proces (ffs) !!

Btw, i would switch to MQA if i were you with this great MQA DAC: smaller sizes for the audio and in my setup it sounds even a bit better then DSD 64. Try it yourself:

Yes, I MQA works fine but to take advantage of it you’d have to listen to MQA tracks from Tidal/Roon. There are not too many MQA tracks available yet.

Would you care to explain what is going on with the source? I see a Tidal FLAC, but i guess you upsample it in three steps? How you do this? My guess would be that you use software for that. What would that be? Can you say more about the results and why you do it?

Hello @John_Jonczyk and @Richard_Dorland,

Just an update, we’re actively engaged with Mytek in the certification process, and we’re looking into the DSD streaming behavior.

@Richard_Dorland, you can check out our DSP Engine options by clicking on the signal path “light” you see to the right of the Now Playing metadata, clicking the 3 dot options menu, and clicking “DSP Engine”. You can find out more information about our DSP Engine here



Great. Hope the Manhattan II gets certified soon. It is an excellent unit.