DSP bypass for DSD

As title, I want DSD keep in native and my Server not powerful enough for apply DSP on DSD, I don’t have to switch off DSP for every time playing DSD and back on for PCM, hope can put this option in DSP menu


DSD songs are skipped when any convolution DSP is on. It would be nice if Roon could turn DSP off and play the DSD file rather than skipping. Something similar could be adapted to MQA files, too.

My DSP and convolution works fine on DSD files. Check your settings, something is making Roon think it can’t send the files to your DAC.

No response https://community.roonlabs.com/t/dsp-bypass-for-dsd/53991?u=cheung_hon_wah

The current solution is switch off native DSD processing, the convolution will apply in PCM domain then convert back to DSD

Many thanks I will try that. Does that in any way effect DSD sound quality?

Less DSD sweetness, as PCM treated and lossy conversion is inevitable, but still very high quality, so you can try and wait.

Just for your information, ROON working DSD<>PCM at 64bit/352k


Can also do it without conversion to PCM:

Note: DoP is NOT conversion to PCM; there is no sample rate conversion in the signal path.

I have asked in the past and Roon can do convolution or EQ to DSD by using 64bit wide DSD, without actual conversion to PCM. Maybe some of you don’t have systems capable of this, and so conversion to PCM takes place?

My settings for this are SRC turned off, and “yes” to “enable native DSP processing”.

You can stay in DSD domain as long as your machine is powerful enough to do Native DSD processing without stopping playback, and if you try Convolution in DSD 256 barely no fanless system can handle it by reaching 4000k tap length

You can do costum settings…I have my settings to upscale evrything to DSD512…Exept DSD files from my library… Play them natively as is

Actually only Convolution consumed so many calculations power, upsampling to DSD is not the main problem.