DSP only produces awful noise

I was eager to try out Roon 1.3 with DSP support - primarily for the Parametric EQ. I read the release notes, and saw references to being careful because of the possibility of the DSP causing ear or equipment damaging sounds.

Sadly, I’m apparently one of the few that only gets this result. It has never produced anything but ear/equipment damaging sound. Masked by the noise, I can hear the song, but it is completely obliterated by awful digital noise. Voices all sound a bit like Alvin and the Chipmunks (which, to be clear, is not what is being played), but the play time of the tracks seems to be correct.

I’ve tried powering everything down and back up. I’ve tried every stable build of Roon 1.3, and they all do the same thing. The problem occurs with every TIDAL track, and every locally stored track, so it doesn’t seem like a network or TIDAL-specific problem. Disabling DSP makes everything sound normal again.

Suggestions on how I can troubleshoot this issue?


  • Roon 1.3 (build 208) stable (64bit)
  • macOS Sierra (10.12.3)
  • Mac Mini (late 2012) with 16GB RAM
  • Music from TIDAL (does the same from tracks on my local USB drive)

Output Setup:

  • Lynx E22 installed in a Sonnet Thunderbolt enclosure
  • AES cable going to a Schiit Yggdrasil
  • Roon Device Setup
    - Exclusive Mode - enabled
    - Use Integer Mode if Supported - enabled
    - Use Max Hardware Buffer Size - disabled
    - Use Power-of-2 Hardware Buffer Size - disabled

It would probably help if we could see your parametric EQ settings here, but i suspect your are suffering from digital clipping by boosting something and not making the necessary db reduction to stop it clipping.

It’s noise even when flat. Like a really bad digital stutter with the chipmunks singing.

Well, that doesn’t look good then.

Maybe it’s the 32 bit final output, rather than PEQ itself?

Do you get the same if you just have headroom enabled, say with a -0.5db reduction, but no EQ?

Have you tried USB or optical into the schiit to rule out the intermediate steps?

Enabling only Headroom Management at -0.5 sounds the same as the Parametric EQ. Through USB, I don’t have the noise problem. Through the Lynx and AES I have no problems with any other players (i.e., Audirvana), or even Roon without DSP.

I suspect the DSP and Lynx don’t get along, but I don’t know why only that combination would be a problem or how to fix it.

Well, at least that’s narrowed it down a bit for support. No ideas otherwise, sorry.

Thanks for helping to clarify the scenario. Hopefully @support can make sense of the issue.

Hey @badf00d – can you give this a read and let us know if any of the settings recommended there help:

I read the thread you mentioned, and changing to a cap of 24 bits eliminated the noise. Like the other thread mentions, the device is definitely capable of 32-bit with all other players, and also Roon without DSP. Is there anything I can do to help with sorting out what might make the DSP cranky with this configuration at 32-bits?

Ah… Delete…
I should be able to distinguish DSD from DSP… :joy: