DSP oversampling filtered by stream type


(Serge Libotte) #1

Hello, I’ve a Nucleus and I like the SQ of oversampling of red book streaming. The problem is that oversampling of MQA is producing « scratches » due to the limited performances. So I have to disable the DSP oversampling when playing hi-res MQA. It would be convenient to be able to automate this. This is an obvious no brainer when using the wonderful Roon radio feature.
Regards,
Serge.


(Henry) #2

Hi, there shouldn’t be any limitation to what you can do with MQA. Certainly I have experienced no issues upsampling the first unfold to 2 x DSD. How are you doing this and with what gear?


(Peter Lie) #3

Post your signal path when playing MQA when the problem occurs.

Enable Parallelize Sigma-Delta Modulator in DSP settings.


(Serge Libotte) #4

Thanks for your replies.
The setup is Tidal > Nucleus > Ethernet > Devialet Expert 200
I was doing upsampling to max square 2 PCM. I’ve tried with another DAC with no issue so the problem is at Devialet level I think. I realised it happened also with 44/16 sources.

I’m now using upsampling to DSD64 and no more scratches so far.
Processing speed means what exactly?


(simon arnold) #5

It’s how much faster than realtime the CPU is working to process it. If you don’t see anything then it’s working faster than 100 x. You can set upsampling to only be applied on certain sample rates but not formats. You can do this in the DSP menu by choosing custom in sample rate conversion.


(Serge Libotte) #6

Just for the record I’ve no more problem with the PCM hi-res upsampling and the Devialet since I updated the amplifier with last software version.
That’s good news to me as I find PCM conversion superior to DSD64 conversion.