DSP processing - CPU Clock not at max

In the last few days I have been playing with the DSP settings in ROON.
Since my DAC reacts allergic to overdriven DSD data, I need some dB headroom.
I noticed the strange behavior described below.

Figure 1 shows the normal system settings of the core

  • Windows Power Plan is set to Balanced
  • Minimum processor state is set to 10%
  • ROON is doing some DSP processing
  • The processing speed is only 1.1 (and I have playback issues)
  • BUT, the CPU clock is still only at < 1.2GHz (from 3.3 Ghz)!?

Figure 2 shows “tweaked” system settings

  • Minimum processor state is now 90%
  • ROON is doing the same DSP processing
  • The processing speed is now 3.1 (I don’t have playback issues)
  • As expected, CPU speed has risen to 3GHz.

I cannot explain the behavior to myself.
With every other tested program, the CPU clock automatically follows the performance requirements of the program. I don’t want to let the CPU run continuously at 3.3 GHz.
Does anyone have any explanation or workaround for this behavior?

The power-saving settings are throttling the CPU and that’s slowing down your upsampling thread. Now it might be that Roon and the power saving aren’t playing nicely but support will have more to say about that. I’m not a windows user or german speaker so I’ll not try to explain that.

Any particular reason why not? It’ll certainly ease this issue while you’re waiting for support. It’s a pretty beefy machine so you shouldn’t have too many issues. I presume it’s not a laptop with the Xeon processor, I’d personally set the power plan to performance and have done with :wink:

Good luck

Thank you for your reply.
It is a server that runs 24/7. That’s why I don’t want the CPU to run continuously at 100%.
In Germany, electricity is quite expensive and I don’t want to pollute our environment.
The CPU is a low cost Xeon specially selected to save energy (ROON and DSP were not planned at that time).
I thing you are right, at least in this case roon and power saving don’t work well together.

1 Like

:+1: all good reasons and I can only agree but they generally only run when loaded. It could be your DSD upsampling requirements aren’t that green either :wink: