DSP upsampling to DDDAC 1794 DAC

Sorry made a mistake starting this topic.

I am using a Raspberry with Moode audio. My dddac 1794 is max 24 bit / 192 khz pcm. The dac is connected by is i2s.

I would like to up sample to the max settings. Can this be done by the room dsd settings? Is there something to be done in the Moode software? The only change in signal path is that it shows a 64 bit float to 24 bit.

However my dac does not switch to a higher resolution. It remains on 44khz 16 bit.

Anybody any idea?

If you’re using moOde I think you would do better asking in the moOde forum. However, if you’re trying to use the RPi as a Roon endpoint please provide a little more information about your setup.

Describe Your Setup

It’s important that you include all relevant setup information so our team can get a clear understanding of the issue.

Your post should include:

  • Details on your Core machine (OS, Hardware specs)
  • Networking details (especially what hardware you’re using, how everything is connected, and anything notable about how it’s all configured)
  • Audio devices in use
  • Library details (where your music is stored, whether you’re using a streaming service, how many tracks are in your library)

Including these details in your first post helps us resolve your issues faster.

Core: synology 713
Network: single segment, hard wired
Audio device: dddac1794 connected with i2s to moode software on raspberry 3. Is Roon endpoint.

Library is not relevant.

Can you share the specs for the DDDAC 1794. A quick Google suggests this only supports PCM. Nonetheless, you can use Roon’s DSP engine to upsample … click on the Speaker icon and then DSP and you’ll see Sample Rate Conversion. Enable this and use the following KB article to help setup sample rate conversion for your DAC.


PS. It’s be useful to share a screenshot of your DAC Settings and Advanced Settings in Roon.

DDDAC is PCM only, up to 96k in its old form or 192k in the later form. Setting up Roon is twofold. Go into setup for the device and specify 192k as the maximum. Tell it also to convert DSD to PCM. Once done go into DSP, enable sample rate conversion and select Max PCM rate (or power of 2 if it suits).

Hi Henry,

Thank you for saving some time for me.

Pls note the attachment.

What I don’t see is the setting for sample rate.

By the way, does this feature indeed improve the sonic qualities?

Regards Jan

Hi, you are using a phone. They are not fully functional as a remote. You will need a tablet or pc to be able to access the settings by highlighting the section you want.

Great, that did it. Technical and functional is every thing fine now.

Now I have to investigate whether these features contributes to the quality of the sound.

Thank you for your assistanceđź‘Ť.

1 Like