Duplicate Albums from Tidal and One's Collection

When I set it up yesterday, I was asked what type of music I liked and I said Classic Rock, I believe. It then populated my music with Tidal classic rock albums apparently because a lot of the albums were not in my collection. However some were, so now I have duplicates. Is there a way that these Tidal albums can be eliminated, if it already in one’s collection to eliminate confusion. Or maybe I don’t understand how the program is working. In general, one would think that the collection version would sound better than the streaming version.

By the way, I have not had one dropout from Tidal using Roon in comparison to numerous dropouts using the Tidal Chrome browser. :grinning:

Hey slingshot. The Roon guys may have a better answer but I’ve found that if your music is of a different format or higher quality than the Tidal 44.1/24 you can use the focus tool to show only those files you want. Go to the upper left drop down menu, choose albums and in the left corner you’ll see a “focus” button. This brings up slew of options and one of the options is to choose only your “main releases” which focuses on your albums only. And further on the far right click on the “quality” tab and you’ll see many choices for narrowing down what you see when you try and choose music. Of course this won’t help if your albums are the same resolution as Tidal. But hopefully it will help.

Hi @slingshot – more info about focusing on (or removing) Tidal Collection albums can be found here but let me know if you have any more issues.


I have the same issue. Why would Roon not be smart enough to ignore albums already in the collection. I don’t want Tidal duplicates of albums I already own (I doubt anyone does). I can see if it was a Japanese import/remaster but it isn’t. Is a fix coming for this soon? Thank you

Hi, was this ever resolved? I have the same issue now and its really annoying. I tried grouping similar albums by editing them but they still show up individually. If an album is in my library, I don’t want to see a duplicate tidal album.


I may be misunderstanding but I’m not sure that this original thread is about your problem. Nevertheless, if you are having trouble with duplicates, have you got the Show Hidden Tracks And Albums toggle set according to this KB article which also covers grouping alternate versions.

Hi Brian,

Thanks for the reply.

I think my issue has been narrowed down to when you ‘loveheart’ a track on tidal and then either also have the album already in my library OR have the album added and the individual track also added. It then shows up like this, grouping albums seems to work sometimes not others. Any suggestions?

https://ibb.co/HtYmLMp (This only shows the Tidal issues really)

I don’t want to see the same album covers, they should all be together.

Hi @Snook,

I hope I’m not misunderstanding here, but looking at your picture, I see two types of duplication; one where an album is in twice with different formats or versions (e.g. explicit or not, cd or mqa) and the other where you have a single track from an album together with the whole album (e.g. Snarky Puppy). Is it this type you are more concerned about?

For this second type you could try the group alternate versions option. This will force Roon to consider them as different versions of an album and each will appear under the versions tab of the other. Now they can be dealt with as if of the first type.

So back to the first type - Setting the Show Hidden Tracks And Albums toggle should deal with this. Does it not with you? I have tried with your Red Hot Chilli Peppers and Shania Twain examples and a grouped Snarky Puppy pair and have no problem.


1 Like

I discovered that in the settings there was a setting for "Show Hidden Track & Albums’ under General as you said. This was ticked, so anything grouped was showing twice. Thanks for your help BrianW