Duplicate indented track names? [resolved]

I have several albums that have a weird track display that looks like it is treating single tracks as if they were parts of works/compositions. It is easily seen in the following screenshots:

Now there is one thing that these albums have in common: they were albums that were newly added duplicates of existing albums that my ripping program copied to the same album folder with different file names. So there were album folders with two sets of tracks. I moved the files into separate album folders, re-identified them, deleted and reimported, but nothing seems to fix things. Also, there is one unique difference between the two problem albums. The top one is a Boz Skaggs album, and on that one, both versions display the problem, but with the second, a Rolling Stones album, only the newly added version has the issue, while the older version looks fine. In the case of the Rolling Stones album, the old version was FLAC and the new version was DSF. I don’t know if any of that makes any difference.

Is there a fix for this?

Yes. Manually force a re-scan and/or re-identification should help. In my case at least it does.

I’m sorry, I thought I had made clear in my post, I have already manually re-scanned, re-identified, re-analyzed and deleted and re-imported multiple times prior to posting. Nothing works, which is why I’m looking for help here.

I’ve seen this too. Decided to live with this as I know how tough is a new product rollout.
But would be interested to know if it gets fixed.

Sorry Robert, I guess I missed that part of your post. Sorry to hear the solution isn’t as simple as it was in my case.

I just had the same issue, I had some duplicates and deleted them, however Roon still shows a display like the one above even though it only has a path to the one file now. Anyone had any success in fixing this, tried rescans, resyncs, delete add etc.


Another resync and it’s fixed, not sure how or why.

Multiple resyncs have done nothing for me.

have you tried build 204?


Hey Robert – can you try selecting two tracks with the same name (like Come On in your screenshot) and then clicking View File Info (under the three dots menu on the selection bar)?

I’d like to see a screenshot of the file info for the duplicates. A screenshot of your storage settings would be good, too.


I wound up fixing it. Here’s the current situation: updrading to build 204 fixed things with all of the albums that I had the problem with except one. The thing that was different about this album was that the album was in the same folder twice. The tracks had different file names, but there were two complete sets of tracks in the same folder. Once I moved the tracks to a separate folder, the problem went away.


Great, thanks for letting us know!