E/A error while trying to copy from ROCK

Hi @support

I am getting an 0x80007045D error when trying to copy data from my ROCK USB drive to my local drive on a Windows 10 PC.

I am using a NUC with an WD My Book Duo 12 TB attached via USB. Copying files was not a problem until a couple of days ago.

I will need to reboot ROCK in order to get access back to my data.
I have not changed any configuration on my PC.

Anybody else experiencing this?

Hello @Klaus_Kammerer1,

The 0x80007045D error is an I/O error, this indicates that something may have gone wrong on a sector of your WD HD or on the ROCK HD itself. Can you please try a few tests here?

  • If you have a thumb drive and can load some media on it and connect it to the ROCK, does copying tracks from that source work as expected?

  • Are you able to connect the WD drive directly to a Windows PC and try copying some files to/from it successfully?

Hopefully one of these tests will show us where the issue lies, on the ROCK HDD or the WD HDD and will allow us to gather some next steps. I would also highly advise in performing a disk check on your WD drive while it is connected to your Windows machine.

Please let me know if that helps!



I have removed the WD HD from Rock and connected it to my Windows PC. The error was reproducable and obviously was caused by a corrupt file.
The WD Disc utility and chkdsk gave no indication of erros on the HD itself.

I have reconnected the HD to Rock now and will observe.

What I find annyoning though, was that the connection from Rock to the drive was lost due to this error. When I did the file move on windows I got the same error, but I could click on “ignore” and the rest of the files was moved without any problems.
On Rock I totally lost my drive, therefore In Roon I had no access to my music anymore. Isn’t it possible to deal with these things in a more user friendly way? I had to reboot Rock ervytime, in order to get access back.

1 Like

Hi @Klaus_Kammerer1,

Thanks for connecting the drive to your Windows PC and for discovering the file corruption and resolving it, glad to hear that worked!

I will bring up the issue you experienced with the team to see if we can do better here with regards to corruption messages on external hard drives.

Either way, glad to hear that this issue is resolved for you!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.