"Edit Track" tab won't open

Roon 1.3 build 233, not sure if the issue is new to this build or not.

I’m very happy that now we can enter recording date and location per track. I wanted to add this info to some live tracks that appear on various albums.

On one particular single, Bruce Springsteen’s “Streets of Philadelphia” I can’t open the “Edit Track” tab of the Track Editor. None of the four tracks will work, nor does it work with multiple selection. The tabs “Track Options” and “Metadata Preference” show. The “Edit Track” page will just show the animated Roon logo.

I tried re-identifying the album, re-scanning and re-analyzing the tracks, didn’t change a thing. The tracks play fine.

This is on MacOS, RoonServer is running on a MacbookPro, the UI on another MBP.

There is an exception shown in the log every time I access the edit dialog:

    06/07 22:21:47 Critical: scx: System.NullReferenceException: Object reference not set to an instance of an object
      at Sooloos.Broker.Music.MusicDatabase.TryGetValue (System.Int64 performanceid, Sooloos.Broker.Music.PerformanceLiteData& data) [0x00048] in /Users/roon/roon/Broker/Core/music/music_database.cs:2124 
      at Sooloos.Broker.Music.Library.GetPerformanceById (System.Int64 performanceid, System.Boolean quiet) [0x00015] in /Users/roon/roon/Broker/Core/music/music_library.cs:1560 
      at Sooloos.Broker.Music.LibraryEditInfo.GetPerformance (Sooloos.Broker.Music.Library library, System.Nullable`1[T] performanceid) [0x0000e] in /Users/roon/roon/Broker/Core/music/music_library_edit_info.cs:933 
      at Sooloos.Broker.Music.LibraryEditInfo.GetPerformance (Sooloos.Broker.Music.Library library, System.Nullable`1[T] performanceid) [0x00000] in /Users/roon/roon/Broker/Core/music/music_library_edit_info.cs:928 
      at Sooloos.Broker.Music.LibraryEditInfo.Compute (Sooloos.Broker.Music.Library library, Sooloos.Broker.Music.LibraryTrack track) [0x0015b] in /Users/roon/roon/Broker/Core/music/music_library_edit_info.cs:452 
      at Sooloos.Broker.Music.LibraryApi+<GetTrackEditInfo>c__AnonStorey19.<>m__0 (Sooloos.Concurrency.ClientContext clientcx) [0x00078] in /Users/roon/roon/Broker/Core/music/music_library_edit_api.cs:320 
      at Sooloos.Concurrency.SharedState`1+<PostHigh>c__AnonStorey2[THREAD].<>m__0 (System.Object _) [0x00000] in /Users/roon/roon/Broker/Concurrency/broker_concurrency.cs:574 
      at Sooloos.SynchronizationContextThread._Dispatch (Sooloos.SynchronizationContextThread+SendOrPostWrapper& ret) [0x00012] in /Users/roon/roon/RoonBase/threadutils.cs:328 

Full latest log:

Hi @ruediger ---- Thank you for the report and sharing your feedback with us, both are appreciated.

My assumption to this question is “yes”, but just to confirm. Can you please verify that both MBPs are running the latest builds.


Yes, both are on build 233.

Hi @ruediger ---- Thank you for verifying that bit of information for me, very appreciated!

Moving forward I would kindly like to ask you to please perform the following to see if we can trigger a change in behavior here. Please see below.

  1. Please close the application and navigate to the watch folder where the track in question is located.

  2. Once you are in the same directory where the media is stored, please make a copy of the track/tracks and move them to a separate location (temporarily).

  3. Once the media has been copied and is in a safe location, please re-launch roon, navigate to Bruce Springsteen’s “Streets of Philadelphia” and delete the track.

Note: By performing this action the media in the watch folder will be permanently deleted. So please be certain that everything was copied accordingly as cited in the previous step

  1. Once the content has been deleted, please take the copy you made and re-import it into Roon.

  2. Please verify if you are still running into the same behavior while accessing the track editor.


Tried these steps, it didn’t work, the problem is still there.

However, I made a new discovery. If I identify the album manually, Roon has seven versions of it, some with different, more or fewer tracks. My copy is matching the 4-track “Columbia CD Release 1 Jan 1994”. I see this release twice in the list of versions. One is matched automatically by Roon (the one I was/am using) and another one that oddly enough shows all tracks as “not matching”. Both of these “correct” identifications won’t allow me to open the “Edit Track” tab.

But, if I pick a wrong version identification (e.g. the “Columbia CD Release 15 Feb 1994” where the 4th track is a different one), then I can open the Edit tab. Edit also works if I pick the two-track release.

Hi @ruediger ---- Thank you for giving the the proposed test a shot and sharing this latest observation you’ve made with us. The continued feedback is appreciated.

Moving forward, we would like to see if we can replicate this behavior you’re reporting to us in house and wanted to see if you could provide us a copy of the media in question via a dropbox download link in PM.


Hi @ruediger ----- Thank you for touching base with me! Confirming that the media has been received and is in my queue to be tested. Once I have some feedback, I will be sure to follow up with, my thoughts/findings.

Your patience is very appreciated!


here is another small glitch, i have detected during my “Groom & Edit Session”.

When the Album Type is set to “Single”,

I’m not able to edit one or multiple tracks, the screen gets stuck with the moving Roon logo.

I have to set the album type to “Main”, then I can edit the credits, etc.

If I switch back the album type to “Single”, the editing works also. This is repeatable for all my “single” type albums on my Win-PC and Android tablet.

Setup: Roon Core on Sonic Transporter 5, latest version

Is it possible, that you can have a look into this?
Thank you


Thank you for your reply and merging the topics.
I followed the steps in post #4 and it worked well, the track editing was possible.

  • The problem of not being able to edit tracks is with all albums, which were marked by Roon as “single” in album type in the past. And they weren’t edited until now.

  • When I change the album type manually to “main” and then back to “single”, track editing is possible again.

  • New imported albums, which are also recognized as “single” type are working fine.

So, for me, it seems like a kind of “flag” (or “marker”, etc.) inside the database for existing albums (pre v234) marked as “single” which prevents direct track editing with Roon v234. After changing the album type or re-importing the files, the “flag” is correct. It’s just an idea…I’m not an IT specialist :slight_smile:

If you still need my example files, please get back to me, I will send them to you then.

Thank you

Hi @ruediger ---- Thank you for your patience while we have been investigating this behavior you’ve reported to us.

Moving forward, I wanted to let you know that we have implemented a fix addressing this issue which will be implemented during our next build release.