Edits not migrated for local files


I’ve set up Rock on o NUC8i7BEH with a separate internal SSD for my music storage. All working fine apart from missing edits for my local files.

I’ve taken care to follow the instructions.

I disabled my storage location, shut down Roon and copied the music files over the network. I’ve renamed the database folder on my PC.

My backup was previously restored via USB plugged directly into my NUC. The tags I set up for Qobuz have been restored, but it is evident that this is not the case for the local files. My favourited albums in mp3 format are no not favourited. The Qobuz ones are. Also those mp3 albums merged with the Qobuz ones are now separate.

When changing my storage location, was was greeted with this (except the “Roon Optimized Kit Internal Storage” was disabled [I’d previously disabled scans for the previous location]):

I enabled the “Roon Optimized Kit Storage” and Roon has now imported the tracks and marks them as new. The second location is still inaccessible (there’s no music folder to choose when editing, but I gather this is normal). I’m sure the second was linked to the same location as the first before migration.

I’m not sure what to do now. Will restoring the backup work?

Thanks for your help.

Hi Daren,

Did you review this FAQ? How Do I move my files

Particularly Step 6.

Take a look at your current screen:

The Top internal storage should be DISABLED as this is the new location and Roon will see anything here as new. Below it is the old location, which needs to be edited. There is a link under it “edit this folder”. Click that and change THAT storage link to the new location.

Note: Ignore post not pertinent to situation.

I tried that first. There were no folders to select as I mentioned in passing in the post. Sorry for not being clear but I followed the steps carefully and ended up being trumped and thought I might have misunderstood. Naturally I enabled the top link. I was able to access \\Rock\ so thought the Win 10 SMB setting wasn’t to blame.

Try Disabling the Internal Storage. Then plug the external drive back in. Does it the external drive show up as normal?

Note: Ignore the comment not pertinent

Sorry, you will have to talk me through this. The internal storage is in my NUC. How do I disable that?
The music was copied from an internal drive in my PC over the network (took 18 hours).

Sorry, Daren, a bit of too early and too little coffee. I completely misunderstood the original situation as I had missed you migrated machines as well as storage locations. However, the basic gist of the situation is still the same. Roon is seeing any files in the new internal storage as new.

The situation seems to be similar to this thread: How to migrate music data? [resolved]

Since you might need to do another backup of the old Roon and restore, you might try this first,
Disable the current internal storage location by clicking the 3 dots and choosing DISABLE.
Then Edit the original storage location and when get that blank screen you posted, Choose Add Network Share and then add \\ROCK\Data\, like I have done on my ROCK build

And then browse to the music folder and select it.

I tried that but with \Rock\Music, which didn’t work.

I’ve done as you’ve suggested.

I do have my original library back but the local files won’t play:


Sorry, picked the folder too high up. I can now play the files.

Thanks for your help Daniel.

My NUC is working overdrive ATM - is this normal following what I’ve just done:


It’s doing this in clumps of 100- 200 ish files then says complete and then off it goes again…


Even if it sees everything, there will be a re-scan period. Sorry, it seems we crossed posted.

With that many files it can take a bit, but, it seems like it finished.

OK great. I expect it will settle down.

One other thing regarding backups. I had 2 locations - 1 PC internal HDD and 1 external USB HDD.

I can’t access the PC drive now but I guess it’s now a question of plugging in a USB pen drive or external HDD into the NUC and pointing Roon to that?

No it keeps doing clumps, says is complete then starts scanning again.

In terms of making a backup, yes you would use an external USB drive and point Roon to that. You cannot use the internal storage for backups. Well, you could try but that would be a bad idea.

The re-scan can take a while with that many files, you have a very large library. What was the spec of the machine you were originally using?

i5/16gb with no issues.

Did the file edits show up?

Yes thanks.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.