Eero router and ARC

Nucleus +

Got an Eero Pro 6 recently since now ARC can no longer find the Nucleus.
UPPN does not configure automatically.
Looking for instruction.

@user255, welcome to the community. A fellow user here, but can you copy the error message shown in the Settings → Roon ARC tab? Was ARC working before your installed the eero pro 6?

@user255, I also use an Eero Pro 6 and ARC works like a charm. This is my setup:

The Eero sits behind my modem. In the modem settings page I have added a NAT/PAT rule for ARC: set port 55000 open to the Eero IP address (TCP only). Depending on the make of modem, the naming can be different.
Now your Eero has access to this port number.
UPnP is not selected (also safer).

In the Eero Network Settings → Reservations & port forwarding, I have added a Reservation for the Roon Server IP address (your Nucleus). Fill in the address of your Nucleus, set the Port of Port Range to 55000 and select the TCP protocol.
Toggle the Port Forward on.
The UPnP setting is Off.

That should do the trick. Happy ARCing.


This worked for me as well. Thanks! I’ve also got the Core → Eero → Cox modem setup, and I didn’t find any mention of this possibility in the Roon docs. One confusing step for me, though, was the Cox modem admin web page - it acted like it was going to redirect to another Cox page to set up port forwarding, but I really ended up doing those configuration steps in the Cox Wifi phone app.

Hi @user255,

We wanted to follow up here as it’s been some time. Did the above steps work for you?

I have the same configuration with one exception and would like your advice. My xFinity router is in bridge mode to my EERO network (It makes life easier for a number of other devices not to have a separate network from the xFinity router). My core is Nucleus + rev. A. So Nucleus + ->EERO->xRouter in Bridge Mode. Thoughts on how to safely configure for ARC and EEROs?

I am not a network expert, but I assume that the Eero itself is secure enough. Just follow my setup. The most important thing is that the same ports are open.

Thank you. I will give this a try and report back (no pun intended).

Solution worked perfectly. ARC works using the EERO Network Setting as you suggested without any further modifications to the xFinity router in bridge mode. Thank you for taking the time to respond.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.