ELAC Discovery Z3 no longer discovered by Roon

Roon Core Machine

Mac Mini Late 2014
2.8GHz duck cire ubtel i5

Networking Gear & Setup Details

Verizon FIOS
Wifi connection to the Mac Mini

Connected Audio Devices

Aqua Formula DAC connected over USB

Number of Tracks in Library


Description of Issue

I own two ELAC Discovery Z3 speakers and can not get either of them to connect to Roon. One of them used to work. Now, The Settings/Audio option does not show any Z3 devices on the network. I have tried scanning for new devices, installing the latest firmware and resetting to factory settings on the Z3s but neither device is picked up by Roon.

I put in my Wifi password into the Z3s and the LED light on the front shows up solid white, meaning it is connected to the network, but I still do not see the device in Roon.

Other devices on the network can see the Roon core. Those other devices include my iPhone, iMac, and other iPads.

Any ideas what is wrong?

Wow, somehow, both ELAC Z3s showed up in Roon! I have no idea what I did to fix the problem. Let’s see if they’re stable.

1 Like

And I lost one of the ELACs, and now Roon is not reachable. I don’t understand why this system is so unstable. I reboot the MacMini, sometimes it works, other times it does not.

Is it too much to hope that Roon will stay up for weeks and maintain connections to all of the devices?

I’m very frustrated with Roon and I backed it from the beginning as a lifetime supporter.

Can somebody suggest a rock solid Roon setup? If it means I have to ditch the Mac Mini, so be it.

I can tell you what I use that has been “rock solid” and 2 of my endpoints are Z3’s. Mine is a NUC8I7BEH 16GB ram, Samsung M.2 NVMe 250GB for OS and Database, with a Samsung Sata internal drive for my music library. It stays on 24/7 and the Z3’s are always powered on so grab a remote and go. The entertainment system is not always on but when it is the HDMI to receiver and Ethernet to my Dac is instantly available.

Are your Z3’s on Ethernet or Wi-Fi? I use Ethernet now and they never miss a beat. As I recall the Z3’s require a firmware update before it shows up as Roon Ready. Or at least mine did. You’re probably aware of that and that following a factory reset the first update will be needed again before it becomes Roon Ready.

I had my first Z3 on wi-fi before having the house wired and it worked fine most of the time. I’ve read at least one other post here where someone was not satisfied with their Z3 on Wi-Fi.