Embedded Art problem

Core Machine (Operating system/System info/Roon build number)

Linux Roon 1.6 Build 145

I’m understanding how roon prioritizes cover art but am running into a problem. I have jpg(s) in the folder that I DO NOT want to be my cover. I have embedded art that I DO want to be my cover art. Roon always selects what I don’t want and I have made piece with that but I don’t see where there is an option to change it. For me it won’t give me the image that is embedded, only the image(s) in the folder as an option when I go to Edit > Edit Album. Under album artwork I should have the option for the embedded art even if it’s not the largest file. If there are no jpegs in the file it reads my embedded artwork flawlessly, only when there are jpegs in the folder.

So I’ve read some more here and it seems that Roon ignores the embedded art in preference for Album Art, which it gets from a image file in the folder. Now if there is only embedded art then it does not ignore it. I just wish it wouldn’t ignore the embedded art (which is the same for all files in the album) if there were image files. I wish I understood why it can’t present both so I can choose.

Hey @Mike_Falcon – I don’t think we’ve made any changes in this area recently, but let me explain how it’s supposed to work, and if it seems like something is broken please flag down @support again and they’ll have our QA team investigate.

So, in Roon all editing is generally done by choosing preference between 3 “layers” – Roon’s metadata, information from your file tags, and edits you make in Roon. More info on that here.

So, the question here is how to do we populate the “file tag” layer for cover art, and the answer is that we look at all the art we find (both embedded in the media and in the folder alongside the media) and we pick the highest quality art we find that we are confident is the front cover.

I went in some additional detail about this here, and there’s also a feature request linked in that thread about more granular controls some users have requested.

A workaround for this:

Would be to rename the JPGs in the folder to something that lets Roon know these are not what you want used as the front cover. I suspect renaming them to liner.jpg and re-scanning the album would work.

Thanks for the feedback here.

I appreciate you taking the time Mike to look into it. I believe that there is a problem so let me describe it better with images and you can maybe tell me if it’s a problem or I’m not getting it.
I have my file tagged (in Yate) and a cover image selected. I use the same method very frequently and it works as intended UNLESS the folder has an image file in there.

(Dir with image file at bottom)

(File Tagged in yate with appropriate image file)

So I have a jpg in the folder and a different (lower res) image that’s embedded. But all I can see is the image from the folder and do not have an option for the embedded image (See Below). I’m ok with manually changing it myself but I want it to show up. I mostly tag my own stuff since I a lot off my folders are live recordings of albums. I use Roon in multiple ways and I have plenty working embedded images (1000s of albums with the embedded image) but ones that have jpgs in the folder do not give me the option to use the embedded image.


I also understand how changing the Library -> import settings -> Metadata Preferences for Albums -> Artwork works. It’s selecting between Roon supplied artwork or my own. These albums i"m having problems with do not have Roon imagery so that’s not the issue I’m pretty sure. My problem is images in the folder are not giving me the option of selecting the metadata.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.