Empty album place holders in Discography

I get this occasionally, I was idly wondering why?

Hello @Tim_Woodward,

Thanks for sharing that! When you say you get this you are referring to the two missing albums in the screenshot, correct?

The heading says Main albums (209) are the missing albums from your local library or from a streaming service? Can you find those albums under Overview?

If you wait a little, do the empty “squares” populate? What if you go back and return on the screen? If you click on the empty “sqaure” does it take you to the album page, or is the app unresponsive?

Hi @beka,

“Thanks for sharing that! When you say you get this you are referring to the two missing albums in the screenshot, correct?”

Yes that’s right, if I scroll down right now on say Coleman Hawkins discography there are random spaces right throughout the catalogue of his work. Adding up the albums spaces they do indeed add up to the total albums at the top of the page. So for instance Roon says ‘With Billie Holiday (15)’ and there are indeed 15 placeholders, but one of them is blank and empty.

“The heading says Main albums (209) are the missing albums from your local library or from a streaming service? Can you find those albums under Overview?”

This is just a general discography of an artist on the main artist page, from Qobuz, not in my library. In Overview, the Albums in my Library seem to be all there.

"If you wait a little, do the empty “squares” populate? What if you go back and return on the screen?

Well the blank spaces are still there today, in any artist I choose to pick. Not all, and there doesn’t seem to be any specific cause - could it be Qobuz is being too slow and Roon is not bothering to wait? I know the programmers have built in the illusion of speed at the expense of accuracy in certain places that could appear slow - such as search for instance?

If you click on the empty “sqaure” does it take you to the album page, or is the app unresponsive?"

No there is nothing there to click so nothing happens, I know what you mean, is it just the cover pic missing, but no it’s an empty space. It looks to me as though the space holder is there ready, but the app couldn’t load the album link in time so just skipped it. I’ve noticed this before but it just stopped and went away so I forgot about it.

I have noticed Roon radio taking ages to play the next track occasionally recently and also I have found some tracks I click individually don’t play, after ages Roon gives up - whereas if I click play on the entire album it plays. Again I’ve had that before but it just goes away.

By the way nothing has changed with any of my setup so it’s not my end, I would put it down to Qobuz connection (although the Qobuz app is fine) - I wonder if others have noticed Qobuz slow and tracks being skipped? Might be a similar problem.

I can go to pretty much any artist with more than a few albums in their discography and I get blanks - here is Albert King just as an example - there is an album missing between 2014 and 2017 in date order. If I change the sort order this album in this position is still a blank space… weird eh? I’ll just stop playing and do a reboot of ROCK and see what happens?

5 minutes later…

Nope, same album missing - well same space where they should be an album anyway. Just checked iPad remote and same there.

I would log out of Qobuz and back in again but I’m worried that might lose my edits?

Same issue with someone back in February - closed so did it get resolved?

Thank you so much for your detailed posts - they are a wealth of information that will certainly be helpful for our technicians :nerd_face: . I’m looping them in so they can investigate.

It looks like the thread you’ve shared was closed because we never got a reply from the user…:pensive:

Our techs should be able to take it from here though :pray:

2 Likes

All back to normal again! It is obviously a ‘pulling the data from Qobuz’ time out issue, but there are still anomalies which may be related.

When I tried to play Joni Mitchell Blue 192k hires version for example, from the big blue ‘play’ button that plays the whole album, I get ‘this track is not available in Qobuz’ - sometimes for the first, second and third tracks before something plays. If I select the first track alone I can play it fine.

Again surely this is Roon giving up after a few seconds if the track is not delivered from Qobuz within what it thinks is a reasonable time (50th anniversary for this album shot it straight to the top of the streaming charts so… it’s likely very busy on the Qobuz servers!) - wouldn’t it be better to just say… ‘Qobuz is taking a long time to deliver this track!’ then we would know it’s not Roon?

Just to keep this thread going, the blanks are back and I’m almost certain this is linked to Roon being prioritised to appear fast, at the expense of actually loading data if it looks like this might be stalling… that seems to fit the problem of Daily Mixes sometimes showing up and other times not - you can watch the Roon logo spinning and quickly giving up!

Hi @Tim_Woodward

Are you still seeing this?

Do they stay missing or do they eventually load in?

If you open the same artist multiple times, is it always the same albums/spots that are blank?

Hi @dylan - it hasn’t happened for a while, but I notice today album cover art is taking ages to load, and if I go back a step then try again it loads. Looks like a Qobuz issue and probably not related to the blank place holders as the rest of the album info is there just no cover art for a while.

Thanks for the update, @Tim_Woodward. Does the Qobuz artwork not loading happen frequently? Are you seeing this just on Discography or other pages as well?

Ok @dylan I’ve just checked by selecting a random composer’s (Aaron Copland) discography and more than a minute later only the first two rows have loaded artwork for the albums, description, dates etc. are there but no artwork, in some places a dark grey square, others just blank. This is new, and it seems leaving the screen and then going back to it (even just using the back/forward arrows at the top of the screen) is enough to get it going again.

Checking albums in my library from the ‘Albums’ menu doesn’t exhibit the same issue, artwork seems to be intact and already in place for all covers, Qobuz or local, I can’t even catch it out by scrolling pages at a time. Playlists also seem to be populating normally.

Going onto the Qobuz menu and selecting my Favourites exhibits slow loading also, with dark grey placeholders, but not as slow as the Discography page, probably about 5 seconds to load a screen.Similar for Qobuz New Releases Grand Selection. Just to be sure I’ve restarted the NUC with ROCK a couple of times, to no effect.

Thanks for the update, @Tim_Woodward.

For our next steps — Please note the exact local time + date when this issue next occurs and the name of the track that was playing and upload your Roon Logs by using these instructions. The best way to get them over to me would be via Dropbox / Google Drive, but if you don’t have either service please let me know and I can provide alternate upload instructions.

Hi @dylan - sorry about the delay, been out of it with a cold! All is well now so I presume it is a Qobuz thing, or at least something that isn’t related to anything my end - thanks for your attention to the issue :+1:

1 Like

Glad to hear that it’s working now, and I hope you’re feeling better! Enjoy the music :headphones: