Enabling AppleTV passcode

I tried enabling AppleTV 4K version. I get the prompt to enter passcode. I go downstairs and get the 4 digit code. Enter it in Roon and it doesn’t accept it. I’ve tried several times.

Hi Bob,

If you press return/enter after entering the code, does it work. The Save button won’t light up after you enter the code.

Do you have Require Password set to Off under Airplay in the Apple TV Settings? If so, it will still give you the 4 digit code.

Maybe let us know what settings you are using in the Apple TV Airplay Settings.

Cheers, Greg

Airplay was set to everyone now tried anyone on same network. Require password is off. Still fails to accept passcode. This should be simple

Do you get an error message? What version of tvOS are you running on the Apple TV? Settings > General > About.

I’ll move this to Support and flag @support.

Cheers, Greg

1 Like

TV IOS 11.4.1. After I enter the passcode in Roon I get the message that it was not accepted.

Hello @Bob_Lasky,

I’m sorry things are not working as expected here. Let’s get you up and running.

Could you attempt pairing the AppleTV in Roon with “Require Password” set to enabled? This will help us diagnose what component of the system is failing when trying to pair with this option disabled.


1 Like

OK I put a GoPro in front of the downstairs AppleTV and watched for the code while I was upstairs with the Mac Mini is running on. As soon as I saw it I entered it. So I’m guessing it timed out by the time I had gone upstairs before. Seems fine now. I’m able to album artwork and have sound.

Just need an AppleTV Roon app now…

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.