End of track cutoff is consistently premature by several seconds [Solved]

Occurs only when playing from library. Does not occur when streaming.

SonicTransporter, Bluesound Node 2, W4S Dac2, Macintosh 1201’s, Mcintosh XRT30’s.

Also, does not occur is play initiated via Bluesound Node 2. Only if initiated in Roon.

All settings are default. Files in library are all AIFF.

1 Like

Hi @Darro_Angelini ---- Thank you for the report and sharing your feedback with us! The insight is always appreciated and sorry to hear of the troubles.

Moving forward, can you please verify for me where your musical library is being stored/accessed from? Are you making use of the DSP engine when you are playing back? Do you notice this behavior with all sample rates?


Library is on the SonicTransporter - as is Roon Core.

Not using DSP.

Everything so far is red book CD.

Hi @Darro_Angelini ----- Thank you for the follow up and providing the requested feedback, very appreciated!

Continuing forward, can you very which version of the ST you are making use of (i5, i7, APi7) and how big of a musical library is being housed on the unit based on total number of tracks (approx). I am curious, during your troubleshooting of this behavior have you tried hosting your Roon core on another device, say a laptop or desktop computer, to confirm how things respond?


Hi Eric,

Thanks in advance for the help. Yes, there is a minor (annoying) problem, but I must say that I really enjoy Roon. Great vision and great work.

I am using a brand new (2 months old) SonicTransporter i7. Overkill for what I’ve got, but I like it and I won’t have to worry about upgrading. It has the latest operating system update. There are only approximately 3800 - 3900 tracks.
No I have not tried running Roon Core on anything else. My only other option for the near term (until Apple refreshes their laptop line) is a very old MacBook Air which is almost maxed out on disc. I would have to run this over an Ethernet network. Not particularly anxious to do that - but I see where you’re going. If I really have to I’ll give it a try.
I can’t say this for sure, but I don’t think I had this problem prior to the upgrade to Roon 1.4.



Problem has gone away.
It is my misfortune to have to report that it was the proverbial ‘operator error’.

I deleted Roon and reloaded a fresh copy. Viola!

As I was combing through all of the setups before I deleted it, I noticed that one of the audio settings - “resync delay” - had 3000ms set. I didn’t really know if I had done that or if it was a default, so I just decided to flush and reload.

The answer was obvious.

I don’t think this episode is helpful to the Roon community since it really had nothing to do with Roon at all. If I were in charge I would delete this email series so as not to bother or confuse anyone else. Your choice.

Thank you for your diligence, responsiveness, and patience. I continue to enjoy Roon and am more favorably impressed the more I use it.


1 Like

I have been having the same problem with resync delay set at zero. I am running with the value set to 1 second now, the cutoff seems to happen less, but I will continue to experiment.

This topic was automatically closed after 24 hours. New replies are no longer allowed.